summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-11-16 10:15:32 +0100
committerValHue2020-11-16 10:15:32 +0100
commita99def2f6379385a36c9b56d63b7395c4d444589 (patch)
treeac7c17de15e62ba6f8eb17b0be73d41569b54b19
parent3eff969b1a12442402a74499f488388e0cf72381 (diff)
downloadaur-lightpad.tar.gz
Minor Fixs.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d81d1d5f501b..64d832e79472 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = lightpad
pkgdesc = A lightweight, simple and powerful application launcher. Writen in GTK+ 3.0. It is also Wayland compatible.
pkgver = 0.0.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libredeb/lightpad
- arch = any
+ arch = x86_64
license = GPL3
makedepends = gobject-introspection
makedepends = meson
makedepends = ninja
- makedepends = vala
- depends = gtk3
- depends = gnome-menus
- depends = libgee
+ makedepends = vala>=0.28.0
+ depends = cairo>=1.15.0
+ depends = gdk-pixbuf2>=2.36.0
+ depends = glib2>=2.50.0
+ depends = glibc>=2.28.0
+ depends = gtk3>=3.22.0
+ depends = gnome-menus>=3.13.0
+ depends = libgee>=0.18.0
source = lightpad-0.0.8.tar.gz::https://github.com/libredeb/lightpad/releases/download/v0.0.8/lightpad-0.0.8.tar.gz
sha256sums = 59b4328c5c140c948f83007d003ad47486d1ba8c90842462a904574cf0e5dfe5
diff --git a/PKGBUILD b/PKGBUILD
index 96552212b118..bc0121d67e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,24 @@
#
pkgname="lightpad"
pkgver="0.0.8"
-pkgrel="1"
+pkgrel="2"
pkgdesc="A lightweight, simple and powerful application launcher. Writen in GTK+ 3.0. It is also Wayland compatible."
-arch=('any')
+arch=('x86_64')
url="https://github.com/libredeb/${pkgname}"
license=('GPL3')
-depends=('gtk3' 'gnome-menus' 'libgee')
-makedepends=('gobject-introspection' 'meson' 'ninja' 'vala')
+depends=('cairo>=1.15.0' 'gdk-pixbuf2>=2.36.0' 'glib2>=2.50.0' 'glibc>=2.28.0' 'gtk3>=3.22.0' 'gnome-menus>=3.13.0' 'libgee>=0.18.0')
+makedepends=('gobject-introspection' 'meson' 'ninja' 'vala>=0.28.0')
source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('59b4328c5c140c948f83007d003ad47486d1ba8c90842462a904574cf0e5dfe5')
+prepare() {
+ rm -rf build
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- meson build --prefix=/usr
+ arch-meson . build --prefix /usr
ninja -C build
}