summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-11-06 22:03:19 +0100
committerValHue2020-11-06 22:03:19 +0100
commit3eff969b1a12442402a74499f488388e0cf72381 (patch)
tree2422f6f40b442a19e8a1cd1d40e3725a12e9d1be
downloadaur-3eff969b1a12442402a74499f488388e0cf72381.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d81d1d5f501b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lightpad
+ pkgdesc = A lightweight, simple and powerful application launcher. Writen in GTK+ 3.0. It is also Wayland compatible.
+ pkgver = 0.0.8
+ pkgrel = 1
+ url = https://github.com/libredeb/lightpad
+ arch = any
+ license = GPL3
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = gtk3
+ depends = gnome-menus
+ depends = libgee
+ source = lightpad-0.0.8.tar.gz::https://github.com/libredeb/lightpad/releases/download/v0.0.8/lightpad-0.0.8.tar.gz
+ sha256sums = 59b4328c5c140c948f83007d003ad47486d1ba8c90842462a904574cf0e5dfe5
+
+pkgname = lightpad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96552212b118
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
+#
+pkgname="lightpad"
+pkgver="0.0.8"
+pkgrel="1"
+pkgdesc="A lightweight, simple and powerful application launcher. Writen in GTK+ 3.0. It is also Wayland compatible."
+arch=('any')
+url="https://github.com/libredeb/${pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gnome-menus' 'libgee')
+makedepends=('gobject-introspection' 'meson' 'ninja' 'vala')
+
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('59b4328c5c140c948f83007d003ad47486d1ba8c90842462a904574cf0e5dfe5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: set ts=4 sw=4 et syn=sh ft=sh: