summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Mullins2016-03-02 16:50:58 -0500
committerChristopher Mullins2016-03-02 16:50:58 -0500
commit5b67f486aedf5b3cf2d87a471a58590addce6c43 (patch)
treefedb0f90e598ae6b87299b3d6fe03b4e8aed6e7f
parent773e779f5d8a1d91c203d18a25ec50ad4928b2e1 (diff)
downloadaur-5b67f486aedf5b3cf2d87a471a58590addce6c43.tar.gz
Update to v2.1
Also patch one of the ui files to get the include right.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
-rw-r--r--fix_optionsdialog_include.patch11
3 files changed, 40 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e485b2dede1..3a51b33fd4d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,22 @@
# Generated by mksrcinfo v8
-# Sun Dec 27 23:23:18 UTC 2015
+# Wed Mar 2 20:50:49 UTC 2016
pkgbase = lightscreen
pkgdesc = Simple tool to automate the tedious process of saving and cataloging screenshots
- pkgver = 2.0
- pkgrel = 1
+ pkgver = 2.1
+ pkgrel = 2
url = http://lightscreen.com.ar/
arch = i686
arch = x86_64
license = GPL
- depends = qt4
- source = lightscreen-2.0.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v2.0.tar.gz
- sha512sums = b2ce92eb1f09ef447d407ea64c9b5658223230bf91def1327acebd83e343aa94385d7b1c48dcb8ae0be90bf6eb8133d4781e7cb5f5b5934f017af8ffa1133112
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-xmlpatterns
+ depends = qt5-multimedia
+ depends = qt5-x11extras
+ source = lightscreen-2.1.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v2.1.tar.gz
+ source = fix_optionsdialog_include.patch
+ sha512sums = c824970c789c2d3ab3410522a95e773dd34689dc3b144a28e555e4a4e332730be5931d103dcae28292776b69137b33ddc937e98128a909c70580caeeed322e15
+ sha512sums = c4ea7c0be83b989c1b971eb8b73686ffe52467d0d2e6d21ebb6e700961626612388411d9984df8d0a1c0748196db0ec4f9da125b398d4668e97e0566a1b20606
pkgname = lightscreen
diff --git a/PKGBUILD b/PKGBUILD
index c6f823fa208b..d3fc4d703011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
# Maintainer: Chris <christopher.r.mullins g-mail>
pkgname=lightscreen
-pkgver=2.0
-pkgrel=1
+pkgver=2.1
+pkgrel=2
pkgdesc='Simple tool to automate the tedious process of saving and cataloging screenshots'
arch=('i686' 'x86_64')
url='http://lightscreen.com.ar/'
-depends=('qt4')
+depends=('qt5-base'
+ 'qt5-declarative'
+ 'qt5-xmlpatterns'
+ 'qt5-multimedia'
+ 'qt5-x11extras')
license=('GPL')
-source=("lightscreen-$pkgver.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v$pkgver.tar.gz")
-sha512sums=('b2ce92eb1f09ef447d407ea64c9b5658223230bf91def1327acebd83e343aa94385d7b1c48dcb8ae0be90bf6eb8133d4781e7cb5f5b5934f017af8ffa1133112')
+source=("lightscreen-$pkgver.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v$pkgver.tar.gz"
+ "fix_optionsdialog_include.patch")
+sha512sums=('c824970c789c2d3ab3410522a95e773dd34689dc3b144a28e555e4a4e332730be5931d103dcae28292776b69137b33ddc937e98128a909c70580caeeed322e15'
+ 'c4ea7c0be83b989c1b971eb8b73686ffe52467d0d2e6d21ebb6e700961626612388411d9984df8d0a1c0748196db0ec4f9da125b398d4668e97e0566a1b20606')
+
+prepare() {
+ cd "${srcdir}"/"Lightscreen-${pkgver}"
+ patch -Np0 -i ../../fix_optionsdialog_include.patch
+}
build() {
cd "Lightscreen-$pkgver"
- qmake-qt4
+ qmake-qt5
make
}
diff --git a/fix_optionsdialog_include.patch b/fix_optionsdialog_include.patch
new file mode 100644
index 000000000000..3bb66819e671
--- /dev/null
+++ b/fix_optionsdialog_include.patch
@@ -0,0 +1,11 @@
+--- dialogs/optionsdialog.ui 2016-03-02 15:33:30.949620295 -0500
++++ dialogs/optionsdialog.ui 2016-03-02 15:34:02.076442579 -0500
+@@ -1386,7 +1386,7 @@
+ <customwidget>
+ <class>HotkeyWidget</class>
+ <extends>QPushButton</extends>
+- <header>../widgets/hotkeywidget.h</header>
++ <header>widgets/hotkeywidget.h</header>
+ </customwidget>
+ </customwidgets>
+ <tabstops>