summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouis Opter2015-09-04 00:33:50 -0700
committerLouis Opter2015-09-04 00:33:50 -0700
commit873844788f56aac1dcef4982b33b588bd9bd268d (patch)
tree4edf7726d7239469878989fb8acac19373506cff
downloadaur-873844788f56aac1dcef4982b33b588bd9bd268d.tar.gz
lightsd, a daemon written in C to control LIFX wifi smart bulbs
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0acdcb26fc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lightsd
+ pkgdesc = Daemon to control your LIFX smart bulbs via a JSON-RPC API
+ pkgver = 0.9.1
+ pkgrel = 1
+ epoch = 1
+ url = https://www.github.com/lopter/lightsd/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake>=2.8.11
+ depends = libevent>=2.0.19
+ depends = libbsd>=0.5.0
+ optdepends = python: to run the interactive lightsc.py example client
+ source = https://api.github.com/repos/lopter/lightsd/tarball/0.9.1
+ sha256sums = ef4f8056bf39c8f2c440e442f047cafce1c102e565bb007791a27f77588157c2
+
+pkgname = lightsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51b01915d86a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Louis Opter <kalessin@kalessin.fr>
+
+pkgname=lightsd
+pkgver=0.9.1
+pkgrel=1
+epoch=1
+pkgdesc="Daemon to control your LIFX smart bulbs via a JSON-RPC API"
+arch=("i686" "x86_64")
+url="https://www.github.com/lopter/lightsd/"
+license=("GPL3")
+depends=("libevent>=2.0.19" "libbsd>=0.5.0")
+optdepends=("python: to run the interactive lightsc.py example client")
+makedepends=("cmake>=2.8.11")
+source=("https://api.github.com/repos/lopter/$pkgname/tarball/$pkgver")
+sha256sums=("ef4f8056bf39c8f2c440e442f047cafce1c102e565bb007791a27f77588157c2")
+
+prepare() {
+ cd "$srcdir"
+
+ mv lopter-lightsd-* "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}