summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-03-21 15:16:50 -0400
committeréclairevoyant2023-03-21 15:16:50 -0400
commitabe492f1c4d7c425bc830dd19c361036bb7dfc51 (patch)
tree64237d2e2dae5a7bba9ea5f0996c815079423724
parentb8d4ea9558a5ef9a0373a1c514893440e7b6d5cf (diff)
downloadaur-lightspark-git.tar.gz
lightspark-git: update url, pkgver()
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD56
3 files changed, 37 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8cd3219fc93..6efe5a8092c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lightspark-git
- pkgdesc = An open source flash player implementation
- pkgver = 0.8.3.r9.g50645853
+ pkgdesc = Open source Flash player implementation
+ pkgver = 0.8.6.1.r123.111064f9
pkgrel = 1
- url = http://lightspark.sourceforge.net
+ url = https://lightspark.github.io
arch = i686
arch = x86_64
license = LGPL3
@@ -21,8 +21,7 @@ pkgbase = lightspark-git
optdepends = gnash-gtk: Gnash fallback support
provides = lightspark
conflicts = lightspark
- source = lightspark-git::git+https://github.com/lightspark/lightspark.git
- md5sums = SKIP
+ source = git+https://github.com/lightspark/lightspark.git
+ b2sums = SKIP
pkgname = lightspark-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 0c77c6bcc577..8250469d4a7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,43 @@
-# Maintainer: Michael Riegert <michael at eowyn net>
-# Contributor: Alad Wenter <alad@archlinux.info>
-# Contributor: Daniel Landau <daniel+aur@landau.fi>
+# Maintainer: éclairevoyant
+# Contributor: Michael Riegert <michael at eowyn net>
+# Contributor: Alad Wenter <alad at archlinux dot info>
+# Contributor: Daniel Landau <daniel+aur at landau dot fi>
# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
# Contributor: mmm
# Contributor: bslackr <brendan at vastactive dot com>
-# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Jan "heftig" Steffens <jan dot steffens at gmail dot com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
-pkgname=lightspark-git
-pkgver=0.8.3.r9.g50645853
+
+_pkgname=lightspark
+pkgname="$_pkgname-git"
+pkgver=0.8.6.1.r123.111064f9
pkgrel=1
-pkgdesc="An open source flash player implementation"
-arch=('i686' 'x86_64')
-url="http://lightspark.sourceforge.net"
-license=('LGPL3')
-depends=('boost-libs' 'glew' 'ffmpeg' 'rtmpdump' 'sdl2_mixer' 'glibmm' 'pango')
-makedepends=('git' 'cmake' 'nasm' 'llvm' 'boost')
+pkgdesc="Open source Flash player implementation"
+arch=(i686 x86_64)
+url="https://lightspark.github.io"
+license=(LGPL3)
+depends=(boost-libs glew ffmpeg rtmpdump sdl2_mixer glibmm pango)
+makedepends=(git cmake nasm llvm boost)
optdepends=('gnash-gtk: Gnash fallback support')
-provides=('lightspark')
-conflicts=('lightspark')
-source=("$pkgname::git+https://github.com/lightspark/lightspark.git")
-md5sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lightspark/$_pkgname.git")
+b2sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed -r 's/^lightspark-//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags --exclude latest | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DGNASH_EXE_PATH=/usr/bin/gtk-gnash .
- make
+ cd $_pkgname
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DGNASH_EXE_PATH=/usr/bin/gtk-gnash .
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ make -C$_pkgname DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: