summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2021-01-04 21:32:27 +0100
committerSefa Eyeoglu2021-01-04 21:32:27 +0100
commitfc2f7297ccfbe8a9aea0f54219278e686b82d8da (patch)
treeca3f9781050adb569535321927bb5157ad179188
downloadaur-fc2f7297ccfbe8a9aea0f54219278e686b82d8da.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0983fa0a685f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lightspeed-react-git
+ pkgdesc = React frontend for the Lightspeed project
+ pkgver = r9.e299491
+ pkgrel = 1
+ url = https://github.com/GRVYDEV/Lightspeed-react
+ arch = any
+ license = custom:MIT
+ makedepends = npm
+ makedepends = git
+ depends = lightspeed-webrtc
+ optdepends = nginx: Web Server to host the static web app
+ provides = lightspeed-react
+ provides = lightspeed-frontend
+ conflicts = lightspeed-react
+ conflicts = lightspeed-frontend
+ source = lightspeed-react-git::git+https://github.com/GRVYDEV/Lightspeed-react.git
+ sha512sums = SKIP
+
+pkgname = lightspeed-react-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c50a56f4e07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+pkgname=lightspeed-react-git
+pkgver=r9.e299491
+pkgrel=1
+pkgdesc="React frontend for the Lightspeed project"
+arch=(any)
+url="https://github.com/GRVYDEV/Lightspeed-react"
+license=("custom:MIT")
+depends=("lightspeed-webrtc")
+optdepends=("nginx: Web Server to host the static web app")
+makedepends=("npm" "git")
+provides=("lightspeed-react" "lightspeed-frontend")
+conflicts=("lightspeed-react" "lightspeed-frontend")
+source=("${pkgname}::git+https://github.com/GRVYDEV/Lightspeed-react.git")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+
+ npm install --cache "${srcdir}/npm-cache"
+}
+
+build() {
+ cd "$pkgname"
+
+ npm run build
+}
+
+package() {
+ cd "$pkgname"
+
+ find "build" -type f -exec install -Dm 644 -t "${pkgdir}/usr/share/webapps/lightspeed-react" "{}" \;
+
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/lightspeed-react/README.md"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}