summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Ayvazian2019-08-12 19:08:05 -0700
committerJordan Ayvazian2019-08-12 19:08:05 -0700
commit9a809c814f05b01feb47ddc41e197fe6d6d62042 (patch)
tree838d44a91da100a1124fe71a673d5430de83e028
downloadaur-9a809c814f05b01feb47ddc41e197fe6d6d62042.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8866ba87084b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lightpp
+ pkgdesc = A C++ API for interacting with phillips hue lights
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/jorbo/lightsplusplus
+ arch = x86_64
+ license = GPL
+ depends = gcc
+ depends = git
+ depends = libcurlpp
+ depends = jsoncpp
+
+pkgname = lightpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cecb4ec8c41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jordan Ayvazian <jaayvazian@gmail.com>
+pkgname=lightpp
+pkgver=0.2
+pkgrel=1
+pkgdesc="A C++ API for interacting with phillips hue lights"
+arch=('x86_64')
+url="https://github.com/jorbo/lightsplusplus"
+license=('GPL')
+depends=('gcc' 'git' 'libcurlpp' 'jsoncpp')
+
+build() {
+ git clone https://github.com/jorbo/lightsplusplus
+ cd lightsplusplus
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd lightsplusplus/build
+ sudo cp src/liblightsplusplus.a /usr/lib
+}