summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Nagel2015-06-14 10:46:34 +0200
committerGeorg Nagel2015-06-14 10:46:34 +0200
commita70eceeb76154443730e09af12927e05df616b01 (patch)
treeb98ef17c3fcb98d1edd2e66ca809da45584f47f6
downloadaur-a70eceeb76154443730e09af12927e05df616b01.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD60
-rw-r--r--lighttpd2.install22
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e636a8a04d76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lighttpd2-git
+ pkgdesc = The new Lighty: A small, secure, scalable, flexible webserver
+ pkgver = 1544.b37d95f
+ pkgrel = 1
+ url = http://redmine.lighttpd.net/wiki/lighttpd2/
+ install = lighttpd2.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = pkg-config
+ makedepends = git
+ depends = libev
+ depends = ragel
+ depends = lua51
+ depends = zlib
+ depends = bzip2
+ depends = openssl
+ depends = glib2
+ optdepends = valgrind: for deep debuggins
+ backup = etc/lighttpd2/lighttpd.conf
+ backup = etc/lighttpd2/angel.conf
+ backup = etc/lighttpd2/mimetypes.conf
+ source = lighttpd2-git::git+https://git.lighttpd.net/lighttpd/lighttpd2.git
+ sha256sums = SKIP
+
+pkgname = lighttpd2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d00761794bf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Georg Nagel <g.schlmm at gmail dot com>
+
+pkgname=lighttpd2-git
+pkgver=1544.b37d95f
+pkgrel=1
+pkgdesc="The new Lighty: A small, secure, scalable, flexible webserver"
+arch=(i686 x86_64)
+url="http://redmine.lighttpd.net/wiki/lighttpd2/"
+license=('MIT')
+depends=("libev" "ragel" "lua51" "zlib" "bzip2" "openssl" "glib2")
+optdepends=("valgrind: for deep debuggins")
+makedepends=("pkg-config" "git")
+backup=('etc/lighttpd2/lighttpd.conf' 'etc/lighttpd2/angel.conf' 'etc/lighttpd2/mimetypes.conf')
+install=lighttpd2.install
+source=("${pkgname}"::"git+https://git.lighttpd.net/lighttpd/lighttpd2.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ #
+ # BUILD HERE
+ #
+
+ export LUA_LIBS=$(pkg-config --libs lua5.1)
+ export LUA_CFLAGS=$(pkg-config --cflags lua5.1)
+
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/lighttpd-2.0.0 \
+ --with-pid-dir=/run \
+ --with-lua \
+ --with-openssl \
+ --with-kerberos5 \
+ --with-zlib \
+ --with-bzip2 \
+ --includedir=/usr/include/lighttpd-2.0.0
+
+ make
+ sed -i -e 's/^docroot "\/var\/www";/docroot "\/srv\/http";/' contrib/lighttpd.conf
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+ install -D -d "$pkgdir/etc/sv/lighttpd2"
+ install -D -d "$pkgdir/var/log/lighttpd2"
+
+ install -D -m0644 contrib/lighttpd.conf "$pkgdir/etc/lighttpd2/lighttpd.conf"
+ install -D -m0644 contrib/angel.conf "$pkgdir/etc/lighttpd2/angel.conf"
+ install -D -m0644 contrib/mimetypes.conf "$pkgdir/etc/lighttpd2/mimetypes.conf"
+ install -D -m0644 contrib/systemd/lighttpd2.service "$pkgdir/usr/lib/systemd/system/lighttpd2.service"
+}
diff --git a/lighttpd2.install b/lighttpd2.install
new file mode 100644
index 000000000000..c7c906d0ce2d
--- /dev/null
+++ b/lighttpd2.install
@@ -0,0 +1,22 @@
+pre_install() {
+ getent group www-data > /dev/null
+ if [ $? -ne 0 ];then
+ echo 'Adding group www-data'
+ groupadd -r www-data
+ fi
+ id www-data > /dev/null
+ if [ $? -ne 0 ];then
+ echo 'Adding user www-data'
+ useradd -r www-data -g www-data
+ fi
+}
+
+post_install() {
+ echo "Lighttpd2 is installed, start with
+ systemctl start lighttpd2
+ or
+ /usr/sbin/lighttpd2 -c /etc/lighttpd2/angel.conf or link /etc/sv/lighttpd2 to your
+ supervised runit directory."
+}
+
+# vim:set ts=2 sw=2 et: