summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyanJMC2021-01-08 16:21:55 -0300
committerShyanJMC2021-01-08 16:21:55 -0300
commit105e451d02f1ceb56d012817fe0981a1c0614998 (patch)
tree33c67c57fea18bc4e3beef457cb4ba1e8c4e0b41
parent7bc559578170a13a59f166c328cae88cd020f8a2 (diff)
downloadaur-105e451d02f1ceb56d012817fe0981a1c0614998.tar.gz
Minor updates for fixing two issues.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5744491bc93d..15d9f2fb7acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ build() {
cd lighttpd1.4
bash autogen.sh
## -enable-static and --disable-shared is for not share libs with the system, all to the binary file. Rest are features disabled. The CFLAGS are the flags/arguments passed to gcc when build the binary or parts.
- ./configure CC=gcc CFLAGS="-g -march=native -O2 -Wall -W -Wshadow -pedantic" -enable-static --disable-shared --without-lua --without-ldap --without-attr --without-valgrind --without-libunwind --without-krb5 --without-nss -without-pcre --without-zlib --without-bzip2 --without-brotli --without-fam --without-webdav-props --without-libxml --without-sqlite --without-webdav-locks --without-uuid --without-xxhash --without-gdbm --without-geoip --without-maxminddb --without-memcached --without-sasl --without-krb5 --without-brotli --without-dbi --without-pgsql --without-mysql --without-nettle --without-nss --without-openssl --without-zlib
+ ./configure CC=gcc CFLAGS="-g -march=native -O2 -Wall -W -Wshadow -pedantic" --enable-static --disable-shared --without-lua --without-ldap --without-attr --without-valgrind --without-libunwind --without-krb5 --without-nss -without-pcre --without-zlib --without-bzip2 --without-brotli --without-fam --without-webdav-props --without-libxml --without-sqlite --without-webdav-locks --without-uuid --without-xxhash --without-gdbm --without-geoip --without-maxminddb --without-memcached --without-sasl --without-krb5 --without-brotli --without-dbi --without-pgsql --without-mysql --without-nettle --without-nss --without-openssl --without-zlib
make
}
@@ -31,5 +31,6 @@ build() {
package() {
cd lighttpd1.4
make DESTDIR="$pkgdir/" install
+ libtool --finish $pkgdir/usr/local/lib
}