summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirk Gleason2016-12-22 16:09:59 -0500
committerKirk Gleason2016-12-22 16:09:59 -0500
commita70a2299879d2800332b3221620b244f07972289 (patch)
tree3c0f1a2a9b16eba2f4837562eb3c6bb581f4e8a4
parentca27a2d50fbb9cc7d64cbed70ff77dafb258d724 (diff)
downloadaur-a70a2299879d2800332b3221620b244f07972289.tar.gz
Community patches so it builds again.
-rw-r--r--PKGBUILD4
-rw-r--r--lightum-git.diff14
2 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 079c06c63a72..b733bec563f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,7 @@ pkgver=2.3.1
pkgrel=1
pkgdesc="Lightum is a daemon to control the keyboard brightness and screen backlight on MacBook based laptops."
arch=(i386 x86_64)
+depends=(dbus glib2 libsystemd libx11 libxext libxss glibc)
url="https://github.com/poliva/lightum"
license=('GPL2')
md5sums=(SKIP)
@@ -16,6 +17,7 @@ pkgver() {
prepare() {
cd "$pkgname"
+ patch -p1 -i ../../lightum-git.diff
}
build() {
@@ -31,4 +33,4 @@ check() {
package() {
cd "$pkgname"
make DESTDIR="$pkgdir/" install
-}
+} \ No newline at end of file
diff --git a/lightum-git.diff b/lightum-git.diff
new file mode 100644
index 000000000000..8507f9746fca
--- /dev/null
+++ b/lightum-git.diff
@@ -0,0 +1,14 @@
+diff -Naur lightum-git.orig/Makefile lightum-git/Makefile
+--- lightum-git.orig/Makefile 2016-12-20 20:20:00.987080212 +0100
++++ lightum-git/Makefile 2016-12-20 20:15:15.122803110 +0100
+@@ -2,8 +2,8 @@
+ SHELL = /bin/sh
+ CC?=gcc
+ CDEBUGFLAGS= -g -O2
+-CFLAGS = `pkg-config --cflags dbus-1 --cflags glib-2.0 --cflags gio-2.0 --cflags libsystemd-login` -Wall -Wextra -Wwrite-strings $(CDEBUGFLAGS)
+-LDFLAGS= `pkg-config --libs dbus-1 --libs glib-2.0 --libs gio-2.0 --libs libsystemd-login` $(CDEBUGFLAGS) -lX11 -lXext -lXss -lm
++CFLAGS = `pkg-config --cflags dbus-1 --cflags glib-2.0 --cflags gio-2.0 --cflags libsystemd` -Wall -Wextra -Wwrite-strings $(CDEBUGFLAGS)
++LDFLAGS= `pkg-config --libs dbus-1 --libs glib-2.0 --libs gio-2.0 --libs libsystemd` $(CDEBUGFLAGS) -lX11 -lXext -lXss -lm
+ INSTALL = /usr/bin/install -c
+ INSTALLDATA = /usr/bin/install -c -m 644
+