summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Teichmann2024-03-29 17:09:02 +0100
committerTim Teichmann2024-03-29 17:09:02 +0100
commit39bc637d8c32c0bee47376250f426c3a5abe1dd6 (patch)
tree7b6b86da1c93f5045002e0d693f90b2c34cff2ac
downloadaur-39bc637d8c32c0bee47376250f426c3a5abe1dd6.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6020e76f0fff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lightwrite
+ pkgdesc = Lightwrite is a simple sdl2 based text-editor.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/tim-tm/lightwrite
+ arch = x86_64
+ license = MIT
+ makedepends = make
+ makedepends = gcc
+ depends = glibc
+ depends = sdl2
+ depends = sdl2_ttf
+ source = lightwrite-0.1.0::https://github.com/tim-tm/lightwrite/releases/download/v0.1.0/lightwrite-0.1.0.tar.gz
+ md5sums = SKIP
+
+pkgname = lightwrite
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..952c413bf8f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tim Teichmann <teichmanntim@outlook.de>
+pkgname=lightwrite
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Lightwrite is a simple sdl2 based text-editor."
+arch=('x86_64')
+url="https://github.com/tim-tm/lightwrite"
+license=('MIT')
+depends=('glibc' 'sdl2' 'sdl2_ttf')
+makedepends=('make' 'gcc')
+source=("$pkgname-$pkgver::https://github.com/tim-tm/lightwrite/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ sudo make install
+}