summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorInfraBot2023-01-05 22:22:00 +0000
committerInfraBot2023-01-05 22:22:00 +0000
commit9e133a5e00f345aacec027354eb4a843532301ab (patch)
tree5c4c6ea7dcb7c0b215ed1946c8aaf1250bd8cf4e
downloadaur-9e133a5e00f345aacec027354eb4a843532301ab.tar.gz
[Bot] Update Ligo pkg version [ 0.59.0 ]
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa4f80db1e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ligo-bin
+ pkgdesc = High Level Smart Contract Language for Tezos (binary)
+ pkgver = 0.59.0
+ pkgrel = 1
+ url = https://gitlab.com/ligolang/ligo
+ arch = x86_64
+ license = MIT
+ provides = ligo
+ conflicts = ligo
+ conflicts = ligo-next
+ source = https://gitlab.com/ligolang/ligo/-/jobs/3553205311/artifacts/raw/ligo.deb
+ md5sums = SKIP
+
+pkgname = ligo-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ce04caf6bead
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: LigoLang <infra at marigold dot dev>
+pkgname=ligo-bin
+pkgver=0.59.0
+pkgrel=1
+pkgdesc="High Level Smart Contract Language for Tezos (binary)"
+url="https://gitlab.com/ligolang/ligo"
+
+arch=('x86_64')
+license=('MIT')
+
+provides=('ligo')
+conflicts=('ligo' 'ligo-next')
+
+source=(https://gitlab.com/ligolang/ligo/-/jobs/3553205311/artifacts/raw/ligo.deb)
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/"
+ tar xvf data.tar.xz -C .
+}
+
+package() {
+ cd "$srcdir/"
+ cp -r usr ${pkgdir}
+}