summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-15 15:44:06 +0800
committerzxp198210052023-07-15 15:44:06 +0800
commit38b11d10dfde761e1b6c55eb871e72f1d61e6119 (patch)
tree22870813d1edf14dc9a5f9d6d7e23e5206419807
downloadaur-38b11d10dfde761e1b6c55eb871e72f1d61e6119.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--liground.sh8
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85f1ff15f677
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = liground-bin
+ pkgdesc = A free, open-source and modern Chess Variant Analysis GUI for the 21st century
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://ml-research.github.io/liground.github.io/
+ arch = x86_64
+ license = AGPL3
+ depends = bash
+ depends = electron11
+ depends = glibc
+ depends = gcc-libs
+ provides = liground
+ conflicts = liground
+ source = liground-0.4.0.AppImage::https://github.com/ml-research/liground/releases/download/0.4.0/liground-0.4.0-linux.AppImage
+ source = liground.sh
+ sha256sums = 7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4
+ sha256sums = b3dc7b16d4987e336d06de8c8de6ebf1f68a3297a3dd826cab295a6fceb84a31
+
+pkgname = liground-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d03e05e3190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="liground-bin"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A free, open-source and modern Chess Variant Analysis GUI for the 21st century"
+arch=('x86_64')
+url="https://ml-research.github.io/liground.github.io/"
+_githuburl="https://github.com/ml-research/liground"
+license=('AGPL3')
+depends=('bash' 'electron11' 'glibc' 'gcc-libs')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-linux.AppImage"
+ "${pkgname%-bin}.sh")
+sha256sums=('7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4'
+ 'b3dc7b16d4987e336d06de8c8de6ebf1f68a3297a3dd826cab295a6fceb84a31')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/256x256/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ sed "s|AppRun %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ chmod 755 "${pkgdir}/opt/liground/engines"
+} \ No newline at end of file
diff --git a/liground.sh b/liground.sh
new file mode 100644
index 000000000000..f9638cd7a33d
--- /dev/null
+++ b/liground.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron11
+_ASAR="/opt/liground/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file