diff options
author | zxp19821005 | 2024-03-06 13:13:46 +0800 |
---|---|---|
committer | zxp19821005 | 2024-03-06 13:13:46 +0800 |
commit | 995fd34471396c89f8b3c32414e7a7f6fa6d8dab (patch) | |
tree | faedb3714865ec9077f7a7d4323d4b98cd1b5698 | |
parent | 1c3b419e562c4da0f714cf21995e9375d847fd13 (diff) | |
download | aur-995fd34471396c89f8b3c32414e7a7f6fa6d8dab.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 11 | ||||
-rw-r--r-- | PKGBUILD | 11 | ||||
-rw-r--r-- | liground.sh | 3 |
3 files changed, 10 insertions, 15 deletions
@@ -1,20 +1,17 @@ pkgbase = liground-bin pkgdesc = A free, open-source and modern Chess Variant Analysis GUI for the 21st century pkgver = 0.4.0 - pkgrel = 6 + pkgrel = 7 url = https://ml-research.github.io/liground.github.io/ arch = x86_64 license = AGPL-3.0-only - makedepends = squashfuse - depends = electron11 - depends = dbus-glib - depends = libdbusmenu-glib - depends = gtk2 + makedepends = fuse2 + depends = electron11-bin provides = liground=0.4.0 conflicts = liground source = liground-0.4.0.AppImage::https://github.com/ml-research/liground/releases/download/0.4.0/liground-0.4.0-linux.AppImage source = liground.sh sha256sums = 7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4 - sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014 + sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe pkgname = liground-bin @@ -2,7 +2,7 @@ pkgname=liground-bin pkgver=0.4.0 _electronversion=11 -pkgrel=6 +pkgrel=7 pkgdesc="A free, open-source and modern Chess Variant Analysis GUI for the 21st century" arch=('x86_64') url="https://ml-research.github.io/liground.github.io/" @@ -11,20 +11,17 @@ license=('AGPL-3.0-only') provides=("${pkgname%-bin}=${pkgver}") conflicts=("${pkgname%-bin}") depends=( - 'electron11' - 'dbus-glib' - 'libdbusmenu-glib' - 'gtk2' + "electron${_electronversion}-bin" ) makedepends=( - 'squashfuse' + 'fuse2' ) source=( "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-linux.AppImage" "${pkgname%-bin}.sh" ) sha256sums=('7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4' - '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014') + '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe') build() { sed -e "s|@electronversion@|${_electronversion}|g" \ -e "s|@appname@|${pkgname%-bin}|g" \ diff --git a/liground.sh b/liground.sh index f9ced1432cfc..86cb3dc6a9bf 100644 --- a/liground.sh +++ b/liground.sh @@ -1,10 +1,11 @@ -#!/bin/sh +#!/bin/bash set -e _APPDIR="/usr/lib/@appname@" _RUNNAME="${_APPDIR}/@runname@" export PATH="${_APPDIR}:${PATH}" export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}" export ELECTRON_IS_DEV=0 +export ELECTRON_FORCE_IS_PACKAGED=true export NODE_ENV=production cd "${_APPDIR}" if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then |