summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-15 10:34:41 +0800
committerzxp198210052023-11-15 10:34:41 +0800
commitac8c09317a87c2214dcd4b8304e01e144e93238a (patch)
treec93124d51b5df7323f4937c79586a0fe3664ef9c
parentdbcb39ccb4f18280cdb6b595255a3a853921178c (diff)
downloadaur-ac8c09317a87c2214dcd4b8304e01e144e93238a.tar.gz
fix errors
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--liground.sh5
3 files changed, 39 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02ff1bc6f58c..1dcd2a0fcf98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = liground-bin
pkgdesc = A free, open-source and modern Chess Variant Analysis GUI for the 21st century
pkgver = 0.4.0
- pkgrel = 3
+ pkgrel = 4
url = https://ml-research.github.io/liground.github.io/
arch = x86_64
license = AGPL3
- depends = bash
+ makedepends = squashfuse
depends = electron11
- depends = glibc
- depends = gcc-libs
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = liground=0.4.0
conflicts = liground
source = liground-0.4.0.AppImage::https://github.com/ml-research/liground/releases/download/0.4.0/liground-0.4.0-linux.AppImage
source = liground.sh
sha256sums = 7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4
- sha256sums = e8c4962d37d37d9e5c43e4a886af0646df8c0bf296103ed4dd3e3f807ca050d4
+ sha256sums = 6d4a0582113bbeeb99c1fd54948b437d152bdcfc4540e28db4fb5e2ea798cbb6
pkgname = liground-bin
diff --git a/PKGBUILD b/PKGBUILD
index f2212dde5599..e7b5809ce818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,45 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=liground-bin
pkgver=0.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="A free, open-source and modern Chess Variant Analysis GUI for the 21st century"
arch=('x86_64')
url="https://ml-research.github.io/liground.github.io/"
-_githuburl="https://github.com/ml-research/liground"
+_ghurl="https://github.com/ml-research/liground"
license=('AGPL3')
-depends=('bash' 'electron11' 'glibc' 'gcc-libs')
+depends=(
+ 'electron11'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-linux.AppImage"
- "${pkgname%-bin}.sh")
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-linux.AppImage"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4'
- 'e8c4962d37d37d9e5c43e4a886af0646df8c0bf296103ed4dd3e3f807ca050d4')
-prepare() {
+ '6d4a0582113bbeeb99c1fd54948b437d152bdcfc4540e28db4fb5e2ea798cbb6')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root" -type d -exec chmod 755 {} \;
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/resources/${pkgname%-bin}.asar"
- install -Dm644 "${srcdir}/squashfs-root/resources/engines/"*stockfish -t "${pkgdir}/opt/${pkgname%-bin}/resources/engines"
- cp -r "${srcdir}/squashfs-root/static" "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/engines/"*stockfish -t "${pkgdir}/usr/lib/${pkgname%-bin}/engines"
+ cp -r "${srcdir}/squashfs-root/static" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/256x256/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/liground.sh b/liground.sh
index adfa099973c0..45a32a34aee6 100644
--- a/liground.sh
+++ b/liground.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron11
-_ASAR="/opt/liground/resources/liground.asar"
+APPDIR=/usr/lib/liground
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else