summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-14 15:55:51 +0800
committerzxp198210052023-09-14 15:55:51 +0800
commitdbcb39ccb4f18280cdb6b595255a3a853921178c (patch)
tree0b36eeda1a442b486a8cbac1902df7afc110fd98
parent9da4b7d9fe9c5fa4438b3e93d5303bbf01bdd59d (diff)
downloadaur-dbcb39ccb4f18280cdb6b595255a3a853921178c.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--liground.sh2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 623d929fc97c..02ff1bc6f58c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = liground-bin
pkgdesc = A free, open-source and modern Chess Variant Analysis GUI for the 21st century
pkgver = 0.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://ml-research.github.io/liground.github.io/
arch = x86_64
license = AGPL3
@@ -14,6 +14,6 @@ pkgbase = liground-bin
source = liground-0.4.0.AppImage::https://github.com/ml-research/liground/releases/download/0.4.0/liground-0.4.0-linux.AppImage
source = liground.sh
sha256sums = 7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4
- sha256sums = b3dc7b16d4987e336d06de8c8de6ebf1f68a3297a3dd826cab295a6fceb84a31
+ sha256sums = e8c4962d37d37d9e5c43e4a886af0646df8c0bf296103ed4dd3e3f807ca050d4
pkgname = liground-bin
diff --git a/PKGBUILD b/PKGBUILD
index a4a1c28e431b..f2212dde5599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=liground-bin
pkgver=0.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="A free, open-source and modern Chess Variant Analysis GUI for the 21st century"
arch=('x86_64')
url="https://ml-research.github.io/liground.github.io/"
@@ -13,16 +13,17 @@ conflicts=("${pkgname%-bin}")
source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-linux.AppImage"
"${pkgname%-bin}.sh")
sha256sums=('7d0c4994cb489689183b3768952d9199971060dd873037a988c25f8d86cc1ad4'
- 'b3dc7b16d4987e336d06de8c8de6ebf1f68a3297a3dd826cab295a6fceb84a31')
+ 'e8c4962d37d37d9e5c43e4a886af0646df8c0bf296103ed4dd3e3f807ca050d4')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/resources/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/engines/"*stockfish -t "${pkgdir}/opt/${pkgname%-bin}/resources/engines"
+ cp -r "${srcdir}/squashfs-root/static" "${pkgdir}/opt/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/256x256/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- sed "s|AppRun %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- chmod 755 "${pkgdir}/opt/liground/engines"
} \ No newline at end of file
diff --git a/liground.sh b/liground.sh
index f9638cd7a33d..adfa099973c0 100644
--- a/liground.sh
+++ b/liground.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron11
-_ASAR="/opt/liground/app.asar"
+_ASAR="/opt/liground/resources/liground.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else