summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2015-06-08 13:26:19 -0400
committerConnor Behan2015-06-08 13:26:19 -0400
commit2073ce808e32fdb887da212b4c43623c62ba7a29 (patch)
treed07518f496d653f8790d0fa69f832f26bdf87d48
downloadaur-2073ce808e32fdb887da212b4c43623c62ba7a29.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD59
-rw-r--r--lilo.conf28
-rw-r--r--lilo.install5
4 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..addc2781a1a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = lilo-git
+ pkgdesc = Current git tree of a bootloader for Linux
+ pkgver = 164.f85a56e
+ pkgrel = 1
+ url = https://alioth.debian.org/projects/lilo/
+ install = lilo.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = bin86
+ makedepends = sharutils
+ makedepends = git
+ depends = device-mapper
+ depends = coreutils
+ optdepends = perl: to use keytab-lilo
+ provides = lilo
+ replaces = lilo
+ options = !makeflags
+ backup = etc/lilo.conf
+ source = git+https://alioth.debian.org/anonscm/git/lilo/lilo.git
+ source = lilo.conf
+ md5sums = SKIP
+ md5sums = ca2d8cd9b63f11444861939b42df29c1
+
+pkgname = lilo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57a23380325a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Connor Behan <connor.behan@gmail.com>
+# Contributor: Federico Cinelli <cinelli.federico@gmail.com>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=lilo-git
+pkgver=164.f85a56e
+pkgrel=1
+pkgdesc="Current git tree of a bootloader for Linux"
+arch=('i686' 'x86_64')
+url="https://alioth.debian.org/projects/lilo/"
+license=('BSD')
+backup=('etc/lilo.conf')
+depends=('device-mapper' 'coreutils')
+makedepends=('bin86' 'sharutils' 'git')
+optdepends=('perl: to use keytab-lilo')
+install=lilo.install
+options=('!makeflags')
+provides=('lilo')
+replaces=('lilo')
+source=('git+https://alioth.debian.org/anonscm/git/lilo/lilo.git'
+ 'lilo.conf')
+
+pkgver() {
+ cd "${srcdir}"/lilo
+ echo `git rev-list --count master`.`git rev-parse --short master`
+}
+
+build() {
+ cd "${srcdir}"/lilo
+ export LC_ALL=C
+
+ sed -i -e 's/strip lilo.static/strip lilo.static || true/' src/Makefile
+ make all
+}
+
+package() {
+ cd "${srcdir}"/lilo
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}"/lilo.conf "${pkgdir}"/etc/lilo.conf
+ install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+ # All binaries in /usr/bin
+ mkdir "${pkgdir}"/usr/bin
+ mv "${pkgdir}"/sbin/lilo "${pkgdir}"/usr/bin/
+ mv "${pkgdir}"/usr/sbin/* "${pkgdir}"/usr/bin/
+ rm -rf "${pkgdir}"/sbin
+ rm -rf "${pkgdir}"/usr/sbin
+
+ # Avoid conflict with syslinux
+ mv "${pkgdir}"/usr/bin/keytab-lilo "${pkgdir}"/usr/bin/keytab-lilo.pl
+
+ # Remove Debian specific files
+ rm -rf "${pkgdir}"/etc/initramfs
+ rm -rf "${pkgdir}"/etc/kernel
+}
+
+md5sums=('SKIP' 'ca2d8cd9b63f11444861939b42df29c1')
diff --git a/lilo.conf b/lilo.conf
new file mode 100644
index 000000000000..9d42a23336c0
--- /dev/null
+++ b/lilo.conf
@@ -0,0 +1,28 @@
+#
+# /etc/lilo.conf
+#
+
+boot=/dev/hda
+# This line often fixes L40 errors on bootup
+# disk=/dev/hda bios=0x80
+
+default=arch
+timeout=50
+lba32
+prompt
+
+image=/boot/vmlinuz-linux
+ label=arch
+ root=/dev/hda3
+ initrd=/boot/initramfs-linux.img
+ read-only
+
+image=/boot/vmlinuz-linux
+ label=arch-fallback
+ root=/dev/hda3
+ initrd=/boot/initramfs-linux-fallback.img
+ read-only
+
+#other=/dev/hda1
+# label=dos
+
diff --git a/lilo.install b/lilo.install
new file mode 100644
index 000000000000..7375fddf87f3
--- /dev/null
+++ b/lilo.install
@@ -0,0 +1,5 @@
+post_upgrade() {
+ echo
+ echo "If you use the LILO bootloader, you should run 'lilo' after upgrading."
+ echo
+}