summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-11-14 05:54:38 +0100
committerChristopher Arndt2019-11-14 05:54:38 +0100
commit794ce83a7b6f78e725e0317a3c0a2cdc60e747d6 (patch)
treec5bdf99c5a7733a1a5983180a8e374c58c160eed
parent618540db775e73b81b984fb9d4f71f4ec4c1385f (diff)
downloadaur-794ce83a7b6f78e725e0317a3c0a2cdc60e747d6.tar.gz
Add 'liblilv-0.so' to provides (same as non-git package, required by other packages)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--lilv-no-empty-collection-assert.patch28
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b649130ae7d3..62e3e284219e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lilv-git
pkgdesc = A C library interface to the LV2 plug-in standard with Python bindings (git version)
- pkgver = 0.24.5.r1249.36e74a7
+ pkgver = 0.24.6.r1258.425af42
pkgrel = 1
url = http://drobilla.net/software/lilv
arch = i686
@@ -14,13 +14,16 @@ pkgbase = lilv-git
optdepends = bash-completion: completion for bash
optdepends = libsndfile: lv2apply utility
provides = lilv
- provides = lilv=0.24.5
+ provides = lilv=0.24.6
+ provides = liblilv-.so
conflicts = lilv
conflicts = lilv-svn
source = lilv::git+https://gitlab.com/lv2/lilv.git
source = autowaf::git+https://gitlab.com/drobilla/autowaf.git
+ source = lilv-no-empty-collection-assert.patch
md5sums = SKIP
md5sums = SKIP
+ md5sums = 5d60a2514d5f81c5335d9278057bf0ae
pkgname = lilv-git
diff --git a/PKGBUILD b/PKGBUILD
index 99fd66f33fac..d1a25888e1d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.5.r1249.36e74a7
+pkgver=0.24.6.r1258.425af42
pkgrel=1
pkgdesc="A C library interface to the LV2 plug-in standard with Python bindings (git version)"
arch=('i686' 'x86_64')
@@ -16,11 +16,14 @@ optdepends=(
"bash-completion: completion for bash"
"libsndfile: lv2apply utility"
)
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}" "liblilv-${pkver::1}.so")
conflicts=("${_pkgname}" "${_pkgname}-svn")
source=("${_pkgname}::git+https://gitlab.com/lv2/${_pkgname}.git"
- 'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
-md5sums=('SKIP' 'SKIP')
+ 'autowaf::git+https://gitlab.com/drobilla/autowaf.git'
+ 'lilv-no-empty-collection-assert.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ '5d60a2514d5f81c5335d9278057bf0ae')
pkgver() {
@@ -37,9 +40,7 @@ prepare() {
git config submodule.waflib.url "${srcdir}/autowaf"
git submodule update
- # Ugly hack to fix pkgconfig file template
- # https://github.com/drobilla/lilv/issues/30
- sed -i -e 's/^Requires:.*/Requires: @LILV_PKG_DEPS@/' lilv.pc.in
+ patch -p1 -N -i "${srcdir}"/lilv-no-empty-collection-assert.patch
}
check() {
diff --git a/lilv-no-empty-collection-assert.patch b/lilv-no-empty-collection-assert.patch
new file mode 100644
index 000000000000..78bbd9f8e611
--- /dev/null
+++ b/lilv-no-empty-collection-assert.patch
@@ -0,0 +1,28 @@
+diff --git a/bindings/python/lilv.py b/bindings/python/lilv.py
+index c548e98..4eee419 100644
+--- a/bindings/python/lilv.py
++++ b/bindings/python/lilv.py
+@@ -929,7 +929,6 @@ class Plugins(Collection):
+
+ def __init__(self, world, collection):
+ assert type(collection) == POINTER(Plugins)
+- assert collection
+
+ def constructor(world, plugin):
+ return Plugin.wrap(world, plugin)
+@@ -975,7 +974,6 @@ class PluginClasses(Collection):
+
+ def __init__(self, world, collection, owning=False):
+ assert type(collection) == POINTER(PluginClasses)
+- assert collection
+
+ self.owning = owning
+ super(PluginClasses, self).__init__(
+@@ -1027,7 +1025,6 @@ class UIs(Collection):
+
+ def __init__(self, world, collection):
+ assert type(collection) == POINTER(UIs)
+- assert collection
+ super(UIs, self).__init__(
+ world,
+ collection,