summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-05 22:51:24 +0200
committerChristopher Arndt2018-08-05 22:51:24 +0200
commitce2d6b233d5d03fa62562fe2e45f107c0f70d95d (patch)
tree4ac34a9646447a5e9a7cdf9e9eac52646c439438
parenta81585268d7727c598acdafcc33221764a30d52f (diff)
downloadaur-ce2d6b233d5d03fa62562fe2e45f107c0f70d95d.tar.gz
Add 'lv2' to depends (as non-git package does it too)
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a72502c0c46..9aa3dba40972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lilv-git
pkgdesc = A C library interface to the LV2 plug-in standard
- pkgver = 0.24.3.r1153.b52c6ff
+ pkgver = 0.24.3.r1163.9a45b4c
pkgrel = 1
url = http://drobilla.net/software/lilv
arch = i686
@@ -8,8 +8,9 @@ pkgbase = lilv-git
license = custom:ISC
makedepends = subversion
makedepends = swig
- depends = sratom
+ depends = lv2
depends = python-numpy
+ depends = sratom
optdepends = bash-completion: auto-complete words
optdepends = libsndfile: lv2apply utility
provides = lilv=0.24.3
diff --git a/PKGBUILD b/PKGBUILD
index 217ee1e272b9..50d885c4cbc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.3.r1153.b52c6ff
+pkgver=0.24.3.r1163.9a45b4c
pkgrel=1
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/lilv"
license=("custom:ISC")
-depends=('sratom' 'python-numpy')
+depends=('lv2' 'python-numpy' 'sratom')
makedepends=('subversion' 'swig')
optdepends=(
"bash-completion: auto-complete words"
@@ -31,11 +31,11 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python waf configure --prefix=/usr \
- --configdir=/etc \
- --dyn-manifest \
- --bindings
-
+ python waf configure \
+ --prefix=/usr \
+ --configdir=/etc \
+ --dyn-manifest \
+ --bindings
python waf
}