summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-05 22:58:02 +0200
committerChristopher Arndt2018-08-05 22:58:02 +0200
commitd6983be3598f74273c72f29d20b2307aa96c9477 (patch)
tree43090e6e0ce29522dec1e6616b549bbddcc4f097
parentce2d6b233d5d03fa62562fe2e45f107c0f70d95d (diff)
downloadaur-d6983be3598f74273c72f29d20b2307aa96c9477.tar.gz
Install bash completion
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aa3dba40972..4a9f0af07678 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lilv-git
pkgdesc = A C library interface to the LV2 plug-in standard
pkgver = 0.24.3.r1163.9a45b4c
- pkgrel = 1
+ pkgrel = 2
url = http://drobilla.net/software/lilv
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = lilv-git
depends = lv2
depends = python-numpy
depends = sratom
- optdepends = bash-completion: auto-complete words
+ optdepends = bash-completion: completion for bash
optdepends = libsndfile: lv2apply utility
provides = lilv=0.24.3
conflicts = lilv
diff --git a/PKGBUILD b/PKGBUILD
index 50d885c4cbc6..863ec408375f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
pkgver=0.24.3.r1163.9a45b4c
-pkgrel=1
+pkgrel=2
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/lilv"
@@ -13,7 +13,7 @@ license=("custom:ISC")
depends=('lv2' 'python-numpy' 'sratom')
makedepends=('subversion' 'swig')
optdepends=(
- "bash-completion: auto-complete words"
+ "bash-completion: completion for bash"
"libsndfile: lv2apply utility"
)
provides=("${_pkgname}=${pkgver%.r*}")
@@ -43,5 +43,9 @@ package() {
cd "${srcdir}/${_pkgname}"
python waf install --destdir="${pkgdir}"
+ # license
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # bash completion
+ install -Dm644 utils/lilv.bash_completion -t \
+ "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
}