summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-10-20 15:43:09 +0200
committerChristopher Arndt2019-10-20 15:43:09 +0200
commitf9486e1bb0a994b1b38463a86735c2f9bb9d98be (patch)
tree17e7d9c863414243c1cf1cbea6c02b9c7e213ae3
parentc0e6db3b1e2958e959a014950c6a432cc3ef6145 (diff)
downloadaur-f9486e1bb0a994b1b38463a86735c2f9bb9d98be.tar.gz
Update pkgdesc; add 'libsndfile' to makedepends; don't install bash completion twice
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0210b104d3ad..8ad3bc22b878 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = lilv-git
- pkgdesc = A C library interface to the LV2 plug-in standard
- pkgver = 0.24.5.r1218.9091b84
- pkgrel = 2
+ pkgdesc = A C library interface to the LV2 plug-in standard with Python bindings (git version)
+ pkgver = 0.24.5.r1235.d959f44
+ pkgrel = 1
url = http://drobilla.net/software/lilv
arch = i686
arch = x86_64
license = custom:ISC
makedepends = git
+ makedepends = libsndfile
depends = lv2
depends = python
depends = sratom
diff --git a/PKGBUILD b/PKGBUILD
index 5ac03f56139f..c6cc26778542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.5.r1218.9091b84
-pkgrel=2
-pkgdesc="A C library interface to the LV2 plug-in standard"
+pkgver=0.24.5.r1235.d959f44
+pkgrel=1
+pkgdesc="A C library interface to the LV2 plug-in standard with Python bindings (git version)"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/lilv"
license=("custom:ISC")
depends=('lv2' 'python' 'sratom')
-makedepends=('git')
+makedepends=('git' 'libsndfile')
optdepends=(
"bash-completion: completion for bash"
"libsndfile: lv2apply utility"
@@ -22,6 +22,7 @@ source=("${_pkgname}::git+https://gitlab.com/lv2/${_pkgname}.git"
'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
md5sums=('SKIP' 'SKIP')
+
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -54,7 +55,4 @@ package() {
python waf install --destdir="${pkgdir}"
# license
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # bash completion
- install -Dm644 utils/lilv.bash_completion -t \
- "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
}