summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2016-09-01 20:42:44 +0100
committerJonathon Fernyhough2016-09-01 20:54:42 +0100
commit299c965ff58d97a6da41bfbd81f7696979fffd99 (patch)
tree99209065632e616d97864aab3f2caa3f8d1a2309
downloadaur-299c965ff58d97a6da41bfbd81f7696979fffd99.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b0c2cf8b286
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lily
+ pkgdesc = An interpreted language with a focus on expressiveness and type safety
+ pkgver = 0.17
+ pkgrel = 1
+ url = https://beyondred.github.io/lily/
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
+ license = MIT
+ makedepends = cmake
+ provides = lily
+ conflicts = lily
+ source = https://github.com/beyondred/lily/archive/v0.17.tar.gz
+ sha256sums = 08c1b313cfb182f58dcf3ff843ea8fccdb0e9471e8e63d1652600bc899c0e0af
+
+pkgname = lily
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9a0429ebc66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonathon Fernyhough <jonathon@manjaro.org>
+
+pkgname=lily
+pkgver=0.17
+pkgrel=1
+pkgdesc='An interpreted language with a focus on expressiveness and type safety'
+arch=('x86_64' 'i686' 'aarch64' 'armv7h')
+url="https://beyondred.github.io/lily/"
+license=('MIT')
+depends=('glibc')
+makedepends=('cmake')
+provides=('lily')
+conflicts=('lily')
+source=("https://github.com/beyondred/lily/archive/v${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/beyondred/lily/master/license.txt')
+sha256sums=('08c1b313cfb182f58dcf3ff843ea8fccdb0e9471e8e63d1652600bc899c0e0af'
+ 'e169a4a749995ef83c0939127180318e4d436bf47f039967c0c14d0de25c7a61')
+
+prepare() {
+ sed -i 's|"lily"|"include/lily"|' "$srcdir/lily-${pkgver}/src/CMakeLists.txt"
+}
+
+build() {
+ cd "$srcdir/lily-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir/lily-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}