summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-03-11 01:14:19 +0000
committerJonathon Fernyhough2021-03-11 01:14:19 +0000
commit31cd5c182d069dbc4e42915b0c11e9e7c7e2b900 (patch)
treec9ee72046f4b9bb4585fe345846e4a3fc2600eea
parent45cffdf55011050fd0be32d6d4a36f517375a3a0 (diff)
downloadaur-31cd5c182d069dbc4e42915b0c11e9e7c7e2b900.tar.gz
Upstream 1.15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--lily.changelog104
3 files changed, 110 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f68446fdb10e..d4fe395918cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lily
pkgdesc = An interpreted language with a focus on expressiveness and type safety
- pkgver = 1.13
+ pkgver = 1.15
pkgrel = 1
url = http://lily-lang.org/
changelog = lily.changelog
@@ -11,8 +11,8 @@ pkgbase = lily
license = MIT
makedepends = cmake>=3.0.0
depends = glibc
- source = lily-1.13.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v1.13/lily-v1.13.tar.gz
- sha256sums = 9a29df8c759cc97bc9ffd3f76f7fcf774bf8a8c03af126ddf850bc32e1bdf57d
+ source = lily-1.15.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v1.15/lily-v1.15.tar.gz
+ sha256sums = 9ff59e64cb168bd9c476278c1c26015235d1513565f6bc64fd0cb3fae471d13a
pkgname = lily
diff --git a/PKGBUILD b/PKGBUILD
index 9d47a7c00ed1..5fa79cf6d4b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Jonathon Fernyhough <jonathon_at manjaro_org>
+# Maintainer: Jonathon Fernyhough <jonathon+m2+dev>
pkgname=lily
-pkgver=1.13
+pkgver=1.15
pkgrel=1
pkgdesc='An interpreted language with a focus on expressiveness and type safety'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -10,7 +10,7 @@ license=(MIT)
depends=(glibc)
makedepends=('cmake>=3.0.0')
source=($pkgname-$pkgver.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
-sha256sums=('9a29df8c759cc97bc9ffd3f76f7fcf774bf8a8c03af126ddf850bc32e1bdf57d')
+sha256sums=('9ff59e64cb168bd9c476278c1c26015235d1513565f6bc64fd0cb3fae471d13a')
changelog=lily.changelog
_update_changelog() {
diff --git a/lily.changelog b/lily.changelog
index 28d193fda30b..c8caabb546cb 100644
--- a/lily.changelog
+++ b/lily.changelog
@@ -1,3 +1,107 @@
+Version 1.15 (2021-1-10)
+========================
+
+This release fixes several long-standing issues in the tracker, most of which
+were feature requests. Additionally, this release adds coverage builds, which
+will be used more in the next release.
+
+Changes:
+
+* The `gitlab-ci.yml` file has been updated to build an lcov coverage report to
+ the repository's pages. A link is in `README.md` (#477).
+
+* Lily can now be built with msbuild on Windows (#443).
+
+* Coroutines have been moved into a `coroutine` module (#437).
+
+* The builtin module is now called `prelude` (#474).
+
+* Equality operations now involve a jump (#406). This is a breaking change done
+ for extra speed. Conditions such as `if x == y` used to write the equal to a
+ storage, then do a jump based on the storage. Jumping equality operations
+ allow folding that into a single operation. This was inspired by Lua.
+
+* Add basic (native code only) constant support (#436). Constants can be
+ `Double`, `Integer`, or `String`. Dynaload support will be added in a future
+ release.
+
+* Add `subprocess` to predefined modules (#438).
+
+* Introduce forward classes (#440).
+
+* Introduce anonymous blocks (#471).
+
+* Add Hash.each_value (#478) and List.merge (#479) to prelude.
+
+* The development branch is now called `main` (#482).
+
+Fixes:
+
+* Foreign functions can now have generics (#483).
+
+* Rewrote many `String` and `List` methods in prelude (#485). This was done to
+ clear out msvc warnings and fix potential bugs.
+
+* Fix handling of eof in template mode (#487).
+
+* Enums and their variants are now gc tagged where appropriate (#408).
+
+* Fix escaped backslash handling in lambda strings (#486).
+
+* Files opened in append mode can now be written to (#484).
+
+Version 1.14 (2020-10-10)
+=========================
+
+This a small release focused on housekeeping and closing several small bugs.
+
+Changes:
+
+* On Linux, the interpreter now builds with `-Wall -Wextra -Wimplicit-fallthrough=0 -Wsign-compare -Wshadow`. Prior releases used only `-Wall`. All warnings from the new flags have been fixed.
+
+Fixes:
+
+* Add `lily_push_unset` for calling keyopt functions (#356).
+
+* Duplicate keyargs are now blocked (#446).
+
+* Add `lily_return_unit` to builtin functions missing it (#461).
+
+* Fix argument reporting for empty static calls (#462).
+
+* Numeric escapes past 255 are now an error (#463).
+
+* The `self` class can no longer be used to solve generics (#464).
+
+* `Unit` is no longer used for lambda inference (#465). This allows the following to type check:
+
+```
+var v: Function(Integer) = (|a| [a] |> List.shift )
+```
+
+* When raising `KeyError` for a missing `Hash` key, double quote characters are now escaped (#467).
+
+* Fixed being unable to call a generic property that resolved to a `Function` (#468).
+
+```
+class Box[A](public var @v: A) {}
+define f {}
+
+var b = Box(|| f )
+
+b.v()()
+```
+
+* Fix crash when the first arg of a bad keyarg call is given (#469).
+
+```
+define f(:a a: Integer, :b b: String) {}
+
+f(:a "1")
+```
+
+* Fix templates not rendering and/or crashing (#480).
+
Version 1.13 (2020-7-10)
========================