summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-06-18 17:53:25 +0100
committerJonathon Fernyhough2021-06-18 17:53:25 +0100
commit3422947ac97dae5b9e33d3cb62e4dca03a6cf74b (patch)
treec0d6c978ee02551677068d9f6ff9b3f9b604cc98
parent31cd5c182d069dbc4e42915b0c11e9e7c7e2b900 (diff)
downloadaur-3422947ac97dae5b9e33d3cb62e4dca03a6cf74b.tar.gz
upgpkg: lily 1.16-1
upstream release Upstream 1.16
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
-rw-r--r--lily.changelog92
3 files changed, 97 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4fe395918cc..3ebc7f6a5eae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lily
pkgdesc = An interpreted language with a focus on expressiveness and type safety
- pkgver = 1.15
+ pkgver = 1.16
pkgrel = 1
url = http://lily-lang.org/
changelog = lily.changelog
@@ -11,8 +11,7 @@ pkgbase = lily
license = MIT
makedepends = cmake>=3.0.0
depends = glibc
- source = lily-1.15.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v1.15/lily-v1.15.tar.gz
- sha256sums = 9ff59e64cb168bd9c476278c1c26015235d1513565f6bc64fd0cb3fae471d13a
+ source = lily-1.16.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v1.16/lily-v1.16.tar.gz
+ sha256sums = 42f0a63c7e4897d0cd46386c75681c0741688a2ab6cd5271bdb1067d3ab567a2
pkgname = lily
-
diff --git a/PKGBUILD b/PKGBUILD
index 5fa79cf6d4b8..df529794ccaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonathon Fernyhough <jonathon+m2+dev>
pkgname=lily
-pkgver=1.15
+pkgver=1.16
pkgrel=1
pkgdesc='An interpreted language with a focus on expressiveness and type safety'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -10,7 +10,7 @@ license=(MIT)
depends=(glibc)
makedepends=('cmake>=3.0.0')
source=($pkgname-$pkgver.tar.gz::https://gitlab.com/FascinatedBox/lily/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
-sha256sums=('9ff59e64cb168bd9c476278c1c26015235d1513565f6bc64fd0cb3fae471d13a')
+sha256sums=('42f0a63c7e4897d0cd46386c75681c0741688a2ab6cd5271bdb1067d3ab567a2')
changelog=lily.changelog
_update_changelog() {
diff --git a/lily.changelog b/lily.changelog
index c8caabb546cb..395eead05242 100644
--- a/lily.changelog
+++ b/lily.changelog
@@ -1,3 +1,95 @@
+Version 1.16 (2021-4-10)
+========================
+
+This is a massive release with several highlights. Garden has been rewritten,
+and is now 100% Lily code. Additionally, all libraries currently included in it
+were updated for new Lily features, some of which were included in this release
+(notably, exit support).
+
+As of this writing, test coverage is reported to be 99%. 100% is impossible due
+to false positives. Even if it were possible, 100% does not mean that
+combinations that cause problems are covered. What the high amount of coverage
+has done, however, is uncover several bugs that were promptly fixed.
+
+On top of that, this release is jammed with fixes and touchups. Docgen generates
+better info now (variable names and docblocks for native definitions). `fs` is
+basic, but it opens the door to new possibilities.
+
+The next release will be 2.0.
+
+New:
+
+* `fs` module with basic filesystem actions (#496).
+
+* Exit support for `sys` via `sys.exit`, `sys.exit_failure`, and
+ `sys.exit_success`. (#503).
+
+* `with` keyword for nicer destructuring (#508).
+
+* Allow multi case match on empty variants (#475).
+
+* `__dir__` magic constant (#495).
+
+* `\xNN` hex escapes (#472).
+
+* `lily_return_string` API function (#470).
+
+* `ClassEntry.prop_count` added to introspection (#514).
+
+* Configuration option for embedders (`extra_info`) to indicate that the
+ interpreter should store docblocks and variable names for introspection.
+ Defaults to off (#497).
+
+* Allow early exit from a function returning `self` (#499).
+
+* Suitable `Integer` literals automatically coerce to `Byte` without an explicit
+ suffix given (#500).
+
+Changes:
+
+* The website sandbox is now built in a different repository (#488).
+
+* `Findlily.cmake` updated for better Windows support (#504).
+
+* By default, template mode renders to C stdout. If Lily's stdout is closed or
+ set to a read-only `File` during a code tag, the next content section will
+ result in `IOError` being raised (#492).
+
+* Allow raise within a lambda (#512).
+
+* Fix strange error message when trying to call a property that is not a
+ `Function` (#498).
+
+* Fix incorrect reporting of missing keyargs (#513).
+
+* The files `lily_int_opcode.h` and `lily_int_code_iter.h` are no longer
+ included in the install. These were originally provided for
+ `FascinatedBox/lily-dis`, back when opcodes were still being worked out. That
+ library now holds local copies of the files, which have been renamed to
+ `lily_opcode.h` and `lily_code_iter.h` (#502).
+
+* Lambdas were not inferring `Unit` in some cases (#507).
+
+Fixes:
+
+* Hash comparison not observing all elements (#505).
+
+* Cannot import a file starting with a number (#506).
+
+* Crash when closing over a variable in a class constructor (#510).
+
+* Potential crash when comparing variants of different sizes (#489).
+
+* Crash when printing a gc tagged value (#490).
+
+* Crash when an iteration method (such as `List.map`) uses upvalues (#491).
+
+* Crash when a class attempts to inherit an incomplete forward class (#501).
+
+* Potential crash splitting a string (#509).
+
+* `String.find` returning the wrong result when given an offset (#494).
+
Version 1.15 (2021-1-10)
========================