summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-10-11 12:47:48 +0100
committerJonathon Fernyhough2017-10-11 12:47:48 +0100
commitc10554120f4f948fcf453590b6b0a18952973728 (patch)
tree08a7b335bf608b8cafb2fd5070f4ac71e9e97713
parent4bba1b408996b15ce470e27a407e9416a05412a9 (diff)
downloadaur-c10554120f4f948fcf453590b6b0a18952973728.tar.gz
Version 1.2
[upstream] This release introduces a syntax for direct imports `import (x, y) z`, and makes scopes required for class methods. The focus on this release was on cleaning up little internal issues and bugfixing. This release is the first to use codecov to track code coverage. The cleanups and testing done in this release are so that the next release can be jammed with features.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1512342d9137..6c9d4a05ce56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lily
pkgdesc = An interpreted language with a focus on expressiveness and type safety
- pkgver = 1.1
- pkgrel = 2
+ pkgver = 1.2
+ pkgrel = 1
url = http://lily-lang.org/
arch = x86_64
arch = i686
@@ -10,8 +10,8 @@ pkgbase = lily
license = MIT
makedepends = cmake>=3.0.0
depends = glibc
- source = lily-1.1.tar.gz::https://github.com/fascinatedbox/lily/archive/v1.1.tar.gz
- sha256sums = 8d243707c8ee796d492644235134da0edb6b29231f06c568824e1e424e74b64f
+ source = lily-1.2.tar.gz::https://github.com/fascinatedbox/lily/archive/v1.2.tar.gz
+ sha256sums = 0d06bb1e6befc58459c3f15094693127eefefdc14be50c08e5205622c9207aae
pkgname = lily
diff --git a/PKGBUILD b/PKGBUILD
index 7f6d29c1bf81..a6b207c7cc09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_org>
pkgname=lily
-pkgver=1.1
-pkgrel=2
+pkgver=1.2
+pkgrel=1
pkgdesc='An interpreted language with a focus on expressiveness and type safety'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url="http://lily-lang.org/"
@@ -10,7 +10,7 @@ license=('MIT')
depends=('glibc')
makedepends=('cmake>=3.0.0')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/fascinatedbox/lily/archive/v${pkgver}.tar.gz")
-sha256sums=('8d243707c8ee796d492644235134da0edb6b29231f06c568824e1e424e74b64f')
+sha256sums=('0d06bb1e6befc58459c3f15094693127eefefdc14be50c08e5205622c9207aae')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"