summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-01-11 10:40:33 +0000
committerJonathon Fernyhough2018-01-11 10:40:33 +0000
commitdb5a5f8162e9d97f54f20295692a6ae0286867fa (patch)
tree403fb09672d84551e4d71204522b1c8527c0fede
parentc10554120f4f948fcf453590b6b0a18952973728 (diff)
downloadaur-db5a5f8162e9d97f54f20295692a6ae0286867fa.tar.gz
Version 1.3
Lily is now 6 1/2 years old. This release doesn't have many features, but the ones it has are interesting. Forward declarations, static qualifier, and a change to import to make it more robust. The biggest addition is adding keyword arguments (they're handled at parse-time for zero vm cost).
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c9d4a05ce56..66404223f789 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lily
pkgdesc = An interpreted language with a focus on expressiveness and type safety
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = http://lily-lang.org/
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = lily
license = MIT
makedepends = cmake>=3.0.0
depends = glibc
- source = lily-1.2.tar.gz::https://github.com/fascinatedbox/lily/archive/v1.2.tar.gz
- sha256sums = 0d06bb1e6befc58459c3f15094693127eefefdc14be50c08e5205622c9207aae
+ source = lily-1.3.tar.gz::https://github.com/fascinatedbox/lily/archive/v1.3.tar.gz
+ sha256sums = 4764c5c6b9c4974135bf4e6d5f4a7ee175f214a5f1572ad5ae86b4bdb79d1db1
pkgname = lily
diff --git a/PKGBUILD b/PKGBUILD
index a6b207c7cc09..6c95302ade81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_org>
pkgname=lily
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc='An interpreted language with a focus on expressiveness and type safety'
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('glibc')
makedepends=('cmake>=3.0.0')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/fascinatedbox/lily/archive/v${pkgver}.tar.gz")
-sha256sums=('0d06bb1e6befc58459c3f15094693127eefefdc14be50c08e5205622c9207aae')
+sha256sums=('4764c5c6b9c4974135bf4e6d5f4a7ee175f214a5f1572ad5ae86b4bdb79d1db1')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"