summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlis2022-11-23 14:30:07 +0100
committerlis2022-11-23 14:30:07 +0100
commitb3472df2996fc50f24f3d4e9cc11e7ed67c31848 (patch)
treed2b8bf6bb4ebb3a1b90f93d7ff95966a06153f06
parent0597e660797c55ffb1f3fef1384587c60ccafb8d (diff)
downloadaur-b3472df2996fc50f24f3d4e9cc11e7ed67c31848.tar.gz
Support guile 3.0
Building docs is broken with this guile version so has been disabled temporarily
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2abc42ddbce..a1d98caeaf22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lilypond-devel
pkgdesc = Music engraving program (development version)
pkgver = 2.23.80
- pkgrel = 1
+ pkgrel = 2
url = https://lilypond.org
arch = x86_64
groups = pro-audio
@@ -26,7 +26,7 @@ pkgbase = lilypond-devel
depends = ghostscript
depends = glibc
depends = gsfonts
- depends = guile
+ depends = guile>=3.0
optdepends = python: for lilypond-book and other scripts
optdepends = tex-gyre-fonts: for extra fonts
optdepends = ttf-dejavu: for extra fonts
@@ -41,7 +41,7 @@ pkgname = lilypond-devel
depends = ghostscript
depends = glibc
depends = gsfonts
- depends = guile
+ depends = guile>=3.0
depends = libfontconfig.so
depends = libfreetype.so
depends = libglib-2.0.so
diff --git a/PKGBUILD b/PKGBUILD
index b8166995bb4f..f3d923af57b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: lis
+# Contributor: Robert Kubosz <kubosz.robert@gmail.com>
# Contributor: David Runge <dvzrv@archlinux.org>
# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
@@ -9,14 +10,14 @@
pkgname=lilypond-devel
_pkgname=lilypond
pkgver=2.23.80
-pkgrel=1
+pkgrel=2
pkgdesc="Music engraving program (development version)"
arch=('x86_64')
url="https://lilypond.org"
license=('FDL1.3' 'GPL3' 'custom:OFL')
groups=('pro-audio')
# NOTE: use guile only with 2.24.x
-depends=('gcc-libs' 'ghostscript' 'glibc' 'gsfonts' 'guile')
+depends=('gcc-libs' 'ghostscript' 'glibc' 'gsfonts' 'guile>=3.0')
makedepends=('fontconfig' 'fontforge' 'freetype2' 'glib2' 'imagemagick' 'pango'
'python' 'rsync' 't1utils' 'texinfo' 'texlive-core' 'tex-gyre-fonts'
'texlive-langcyrillic' 'zip')
@@ -39,7 +40,9 @@ prepare() {
build() {
cd "$_pkgname-$pkgver"
./configure --prefix=/usr \
- --disable-texi2html
+ --disable-texi2html \
+ --disable-documentation \
+ GUILE_FLAVOR=guile-3.0
make
make bytecode
}