summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:37:13 +0200
committerStefan Husmann2015-06-09 00:37:13 +0200
commite857c6dc54ae28ccd5ab3fd9e6c5dce9c89e0879 (patch)
tree73b7d21f9d25bda082e95201055d79c81fb6c367
downloadaur-e857c6dc54ae28ccd5ab3fd9e6c5dce9c89e0879.tar.gz
initial version
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD69
-rw-r--r--no_fontforge-versioncheck.patch12
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fdd877a719f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = lilypond-devel
+ pkgdesc = An automated music engraving system (development version)
+ pkgver = 2.19.21
+ pkgrel = 1
+ url = http://lilypond.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = fontforge
+ makedepends = gsfonts-cyr
+ makedepends = t1utils
+ makedepends = texlive-core>=2011.23170
+ depends = fontconfig
+ depends = freetype2
+ depends = guile1.8
+ depends = pango
+ depends = python2
+ depends = ghostscript
+ optdepends = netpbm: building HTML documentation
+ optdepends = imagemagick: building HTML documentation
+ optdepends = ttf-kochi-substitute: building HTML documentation
+ optdepends = texi2html>=1.82: building HTML documentation
+ optdepends = rsync: installing HTML documentation
+ provides = lilypond=2.19.21
+ conflicts = lilypond
+ conflicts = lilypond-git
+ source = http://download.linuxaudio.org/lilypond/sources/v2.19/lilypond-2.19.21.tar.gz
+ source = no_fontforge-versioncheck.patch
+ md5sums = d4262b67f61db2e48e45701abc70218f
+ md5sums = 84c92f047d703a4b798092cfc4d83e32
+
+pkgname = lilypond-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46154185f6e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Contributor: Patrick McCarty <pnorcks at gmail dot com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=lilypond-devel
+pkgver=2.19.21
+pkgrel=1
+pkgdesc="An automated music engraving system (development version)"
+arch=('i686' 'x86_64')
+url="http://lilypond.org/"
+license=('GPL')
+depends=('fontconfig'
+ 'freetype2'
+ 'guile1.8'
+ 'pango'
+ 'python2'
+ 'ghostscript')
+makedepends=('fontforge'
+ 'gsfonts-cyr' # from boohomil's infinality-bundle-fonts repo
+ 't1utils'
+ 'texlive-core>=2011.23170')
+optdepends=('netpbm: building HTML documentation'
+ 'imagemagick: building HTML documentation'
+ 'ttf-kochi-substitute: building HTML documentation'
+ 'texi2html>=1.82: building HTML documentation'
+ 'rsync: installing HTML documentation')
+provides=("lilypond=$pkgver")
+conflicts=('lilypond' 'lilypond-git')
+source=(http://download.linuxaudio.org/lilypond/sources/v2.19/lilypond-$pkgver.tar.gz no_fontforge-versioncheck.patch)
+md5sums=('d4262b67f61db2e48e45701abc70218f'
+ '84c92f047d703a4b798092cfc4d83e32')
+
+prepare() {
+ cd "$srcdir/lilypond-$pkgver"
+
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ patch -Np1 < $srcdir/no_fontforge-versioncheck.patch
+ rm -rf python/out/
+}
+
+build() {
+ cd "$srcdir/lilypond-$pkgver"
+
+ export GUILE=/usr/bin/guile
+ export GUILE_CONFIG=/usr/bin/guile-config
+ export PYTHON="python2"
+ export PYTHON_CONFIG="python2-config"
+ export GUILE=/usr/bin/guile1.8
+ export GUILE_CONFIG=/usr/bin/guile-config1.8
+
+ ./autogen.sh --prefix=/usr \
+ --disable-documentation
+
+ # FIXME: the extra LDFLAG should not be needed;
+ # this is a regression somewhere
+ make LDFLAGS+=" -pthread" all
+}
+
+package() {
+ cd "$srcdir/lilypond-$pkgver"
+ make DESTDIR="$pkgdir/" \
+ vimdir="/usr/share/vim/vimfiles" install
+
+ rm -rf "$pkgdir/usr/share/man"
+}
diff --git a/no_fontforge-versioncheck.patch b/no_fontforge-versioncheck.patch
new file mode 100644
index 000000000000..010cdbe7abb3
--- /dev/null
+++ b/no_fontforge-versioncheck.patch
@@ -0,0 +1,12 @@
+diff -Naur lilypond-2.19.16.orig/configure.ac lilypond-2.19.16.new/configure.ac
+--- lilypond-2.19.16.orig/configure.ac 2015-03-03 21:38:23.340077656 +0100
++++ lilypond-2.19.16.new/configure.ac 2015-03-03 21:42:39.231862408 +0100
+@@ -186,7 +186,7 @@
+
+ STEPMAKE_PYTHON_DEVEL(REQUIRED, 2.4, 3.0)
+
+-STEPMAKE_PATH_PROG(FONTFORGE, fontforge, REQUIRED, 20110222)
++STEPMAKE_PATH_PROG(FONTFORGE, fontforge, REQUIRED)
+
+ STEPMAKE_PATH_PROG(T1ASM, t1asm, REQUIRED)
+