summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-07-24 00:10:12 +0200
committerStefan Husmann2016-07-24 00:10:12 +0200
commit11743ba1a4faec12a09be00d6e106fd594bb48c0 (patch)
treeec2b8314ddbc0285205be35cb1cef9c4980c7160
parentedca3314575a90d9eb70871012f807471ecdf60a (diff)
downloadaur-11743ba1a4faec12a09be00d6e106fd594bb48c0.tar.gz
reomve patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--audio-item.patch34
3 files changed, 5 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b971a60ecbd..66d69e078952 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jul 23 16:04:26 UTC 2016
+# Sat Jul 23 22:09:45 UTC 2016
pkgbase = lilypond-git
pkgdesc = An automated music engraving system (Git snapshot)
- pkgver = 2.19.45.1.35.gb0dce76
+ pkgver = 2.19.45.1.36.gb280487
pkgrel = 1
url = http://lilypond.org/
arch = i686
@@ -30,9 +30,7 @@ pkgbase = lilypond-git
conflicts = lilypond-devel
options = !makeflags
source = git://git.sv.gnu.org/lilypond.git
- source = audio-item.patch
md5sums = SKIP
- md5sums = 9795811b1d588296e1b483ec107389ea
pkgname = lilypond-git
diff --git a/PKGBUILD b/PKGBUILD
index a9a5eaef1f36..416bbb476b92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.19.45.1.35.gb0dce76
+pkgver=2.19.45.1.36.gb280487
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -20,9 +20,8 @@ optdepends=('imagemagick: building HTML documentation'
'rsync: installing HTML documentation')
provides=('lilypond')
conflicts=('lilypond' 'lilypond-devel')
-source=(git://git.sv.gnu.org/lilypond.git audio-item.patch)
-md5sums=('SKIP'
- '9795811b1d588296e1b483ec107389ea')
+source=(git://git.sv.gnu.org/lilypond.git)
+md5sums=('SKIP')
options=('!makeflags')
pkgver() {
@@ -43,7 +42,6 @@ prepare() {
sed -i 's|GUILE_LDFLAGS=.*|GUILE_LDFLAGS="`pkg-config --libs guile`"|' configure.ac
rm -rf python/out/
- patch -p1 < "$srcdir"/audio-item.patch
}
build() {
diff --git a/audio-item.patch b/audio-item.patch
deleted file mode 100644
index 9bee3b9233a2..000000000000
--- a/audio-item.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/lily/audio-item.cc b/lily/audio-item.cc
-index 2c5d691..c5b1f87 100644
---- a/lily/audio-item.cc
-+++ b/lily/audio-item.cc
-@@ -102,9 +102,9 @@ Audio_key::Audio_key (int acc, bool major)
- major_ = major;
- }
-
--const Real Audio_span_dynamic::MINIMUM_VOLUME;
--const Real Audio_span_dynamic::MAXIMUM_VOLUME;
--const Real Audio_span_dynamic::DEFAULT_VOLUME;
-+constexpr Real Audio_span_dynamic::MINIMUM_VOLUME;
-+constexpr Real Audio_span_dynamic::MAXIMUM_VOLUME;
-+constexpr Real Audio_span_dynamic::DEFAULT_VOLUME;
-
- Audio_span_dynamic::Audio_span_dynamic (Moment mom, Real volume)
- : start_moment_ (mom),
-diff --git a/lily/include/audio-item.hh b/lily/include/audio-item.hh
-index 597fa6a..9a2eea0 100644
---- a/lily/include/audio-item.hh
-+++ b/lily/include/audio-item.hh
-@@ -48,9 +48,9 @@ private:
- class Audio_span_dynamic : public Audio_element
- {
- public:
-- static const Real MINIMUM_VOLUME = 0.0;
-- static const Real MAXIMUM_VOLUME = 1.0;
-- static const Real DEFAULT_VOLUME = 90.0 / 127.0;
-+ static constexpr Real MINIMUM_VOLUME = 0.0;
-+ static constexpr Real MAXIMUM_VOLUME = 1.0;
-+ static constexpr Real DEFAULT_VOLUME = 90.0 / 127.0;
-
- private:
- Moment start_moment_;