summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-03-28 08:35:42 +0200
committerhaawda2018-03-28 08:35:42 +0200
commit1dde31ef5aadfa72a652c8c341b555e87ac29c40 (patch)
tree93697c691b7e1da8e3ea6bfc26c25615bece8c9d
parent0a28df97b9d0d9c789af8ce9e0d10e575a9f18e8 (diff)
downloadaur-1dde31ef5aadfa72a652c8c341b555e87ac29c40.tar.gz
use t1utils-git for now
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caaed651614a..69f977eaf5e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lilypond-git
pkgdesc = An automated music engraving system (Git snapshot)
- pkgver = 2.19.81.28053
+ pkgver = 2.19.81.28068
pkgrel = 1
url = http://lilypond.org/
arch = i686
@@ -9,8 +9,7 @@ pkgbase = lilypond-git
makedepends = fontforge
makedepends = git
makedepends = gsfonts
- makedepends = t1utils
- makedepends = ghostscript
+ makedepends = t1utils-git
makedepends = dblatex
makedepends = tex-gyre-fonts
makedepends = texlive-langcyrillic
@@ -19,11 +18,12 @@ pkgbase = lilypond-git
depends = guile1.8
depends = pango
depends = python2
- optdepends = imagemagick: building HTML documentation
- optdepends = ttf-kochi-substitute: building HTML documentation
- optdepends = texi2html>=1.82: building HTML documentation
- optdepends = rsync: installing HTML documentation
+ depends = ttf-dejavu
+ depends = fontconfig
+ depends = freetype2
+ depends = ghostscript
optdepends = extractpdfmark: for reducing the size of pdf output significantly
+ optdepends = tk: for the gui
provides = lilypond
conflicts = lilypond
conflicts = lilypond-devel
diff --git a/PKGBUILD b/PKGBUILD
index 159485fc9e70..76fb3d3ab106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,17 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.19.81.28053
+pkgver=2.19.81.28068
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
url="http://lilypond.org/"
license=('GPL')
-depends=('guile1.8' 'pango' 'python2')
-makedepends=('fontforge' 'git' 'gsfonts' 't1utils' 'ghostscript' 'dblatex'
+depends=('guile1.8' 'pango' 'python2' 'ttf-dejavu' 'fontconfig' 'freetype2' 'ghostscript')
+makedepends=('fontforge' 'git' 'gsfonts' 't1utils-git' 'dblatex'
'tex-gyre-fonts' 'texlive-langcyrillic' 'texi2html' 'netpbm')
-optdepends=('imagemagick: building HTML documentation'
- 'ttf-kochi-substitute: building HTML documentation'
- 'texi2html>=1.82: building HTML documentation'
- 'rsync: installing HTML documentation'
- 'extractpdfmark: for reducing the size of pdf output significantly')
+optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
+ 'tk: for the gui')
provides=('lilypond')
conflicts=('lilypond' 'lilypond-devel')
source=(git://git.savannah.gnu.org/lilypond.git)
@@ -45,16 +42,18 @@ build() {
cd lilypond/
export PYTHON="python2"
export PYTHON_CONFIG="python2-config"
- [ -f config.hh ] && rm config.hh
- ./autogen.sh \
- --prefix=/usr \
+ [[ -f config.hh ]] && rm config.hh
+ ./autogen.sh --noconfigure
+ [[ -d build ]] || mkdir build
+ cd build
+ ../configure --prefix=/usr \
--disable-documentation \
--enable-guile2=no
- make all
+ make -j1
}
package() {
- cd lilypond/
+ cd lilypond/build
make DESTDIR="$pkgdir/" vimdir="/usr/share/vim/vimfiles" install
rm -rf "$pkgdir/usr/share/man"
}