summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-05-28 20:41:53 +0200
committerhaawda2022-05-28 20:41:53 +0200
commit71862beab06c26f23d461b49703b193d49956dff (patch)
tree033119e583c170c5e5a3fee8cd09349c6dbb7260
parent18ede9b3e9415fe3d161e7f045da84c95a8c16d2 (diff)
downloadaur-71862beab06c26f23d461b49703b193d49956dff.tar.gz
add patch, pull again from master
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix_buildsystem.patch23
3 files changed, 36 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c2ec3b93e53..684f65045ec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lilypond-git
pkgdesc = An automated music engraving system (Git snapshot)
- pkgver = 2.23b31807.25ffd4b40d
+ pkgver = 2.23b31827.8b533bda3b
pkgrel = 1
url = http://lilypond.org/
arch = i686
@@ -27,7 +27,9 @@ pkgbase = lilypond-git
provides = lilypond
conflicts = lilypond
options = !makeflags
- source = git+https://gitlab.com/lilypond/lilypond.git#branch=dev/wl/fix-install
+ source = git+https://gitlab.com/lilypond/lilypond.git
+ source = fix_buildsystem.patch
sha256sums = SKIP
+ sha256sums = 4c04ea356f87321ab816ce25d28d3301698b8091df5f248f6bdc882cd9953f06
pkgname = lilypond-git
diff --git a/PKGBUILD b/PKGBUILD
index 9af9e1ea0e37..c49ce6ec2d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.23b31807.25ffd4b40d
+pkgver=2.23b31827.8b533bda3b
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -30,8 +30,9 @@ optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
'tk: for the gui')
provides=('lilypond')
conflicts=('lilypond')
-source=(git+https://gitlab.com/lilypond/lilypond.git#branch=dev/wl/fix-install)
-sha256sums=('SKIP')
+source=(git+https://gitlab.com/lilypond/lilypond.git fix_buildsystem.patch)
+sha256sums=('SKIP'
+ '4c04ea356f87321ab816ce25d28d3301698b8091df5f248f6bdc882cd9953f06')
options=('!makeflags')
pkgver() {
@@ -41,6 +42,11 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd lilypond/
+ patch -Np1 < "$srcdir"/fix_buildsystem.patch
+}
+
build() {
cd lilypond/
[[ -f config.hh ]] && rm config.hh
@@ -52,7 +58,6 @@ build() {
}
package() {
- LANG=C
cd lilypond/build
make DESTDIR="$pkgdir/" vimdir="/usr/share/vim/vimfiles" install
rm -rf "$pkgdir"/usr/share/man
diff --git a/fix_buildsystem.patch b/fix_buildsystem.patch
new file mode 100644
index 000000000000..ee164e5e61a3
--- /dev/null
+++ b/fix_buildsystem.patch
@@ -0,0 +1,23 @@
+diff --git a/lily/GNUmakefile b/lily/GNUmakefile
+index c688b836e5..6ce235f257 100644
+--- a/lily/GNUmakefile
++++ b/lily/GNUmakefile
+@@ -103,15 +103,15 @@ $(outdir)/general-scheme.o: $(outdir)/version.hh
+ $(outdir)/lily-version.o: $(outdir)/version.hh
+ $(outdir)/relocate.o: $(outdir)/version.hh
+
+-prefix :={c++}/[ \t]*
++pre :={c++}/[ \t]*
+ second :=[ \t\n\v]*([^,]*,[^""]*\"\([^""]*\)/\1/m
+ third :=[ \t\n\v]*([^,]*,[^,]*,[^""]*\"\([^""]*\)/\1/m
+ three-arg-calls := MAKE_SCHEME_CALLBACK_WITH_OPTARGS MAKE_DOCUMENTED_SCHEME_CALLBACK MAKE_SCHEME_CALLBACK
+ two-arg-calls := LY_DEFINE LY_DEFINE_WITH_SETTER
+
+ regex_ =
+-regex_ += $(foreach fname,$(two-arg-calls),--regex='$(prefix)$(fname)$(second)')
+-regex_ += $(foreach fname,$(three-arg-calls),--regex='$(prefix)$(fname)$(third)')
++regex_ += $(foreach fname,$(two-arg-calls),--regex='$(pre)$(fname)$(second)')
++regex_ += $(foreach fname,$(three-arg-calls),--regex='$(pre)$(fname)$(third)')
+
+ ETAGS_FLAGS += $(regex_)
+ CTAGS_FLAGS += $(regex_)