summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-11-12 13:21:02 +0100
committerhaawda2017-11-12 13:21:02 +0100
commitf5996898befc6b468214c389c5ded02a7d91d629 (patch)
tree84d1e6e9abe1f34d96872da32d27baaa9d667dd7
parent81425e0cf5ad6417fe079f0ff4d74dcadd2bafbd (diff)
downloadaur-f5996898befc6b468214c389c5ded02a7d91d629.tar.gz
rewrite pkgver function to reflect version jump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221f7398d56a..52907a81d926 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Nov 12 01:53:20 UTC 2017
pkgbase = lilypond-git
pkgdesc = An automated music engraving system (Git snapshot)
- pkgver = 2.19.65.1.94.gabef0f722f
+ pkgver = 2.19.80.27998
pkgrel = 1
url = http://lilypond.org/
arch = i686
@@ -29,7 +27,7 @@ pkgbase = lilypond-git
conflicts = lilypond
conflicts = lilypond-devel
options = !makeflags
- source = git://git.sv.gnu.org/lilypond.git
+ source = git://git.savannah.gnu.org/lilypond.git
md5sums = SKIP
pkgname = lilypond-git
diff --git a/PKGBUILD b/PKGBUILD
index 3b532aed7c09..4de2f9a2c787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.19.65.1.94.gabef0f722f
+pkgver=2.19.80.27998
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -20,13 +20,13 @@ optdepends=('imagemagick: building HTML documentation'
'extractpdfmark: for reducing the size of pdf output significantly')
provides=('lilypond')
conflicts=('lilypond' 'lilypond-devel')
-source=(git://git.sv.gnu.org/lilypond.git)
+source=(git://git.savannah.gnu.org/lilypond.git)
md5sums=('SKIP')
options=('!makeflags')
pkgver() {
cd lilypond/
- git describe | sed -e 's|release/\(.*\)|\1|' -e 's|-|.|g'
+ printf %s.%s $(grep VERSION_DEVEL VERSION | cut -d= -f2) $(git rev-list --count HEAD)
}
prepare() {