summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-07-20 20:33:35 +0200
committerStefan Husmann2016-07-20 20:33:35 +0200
commitfaadd40bab37a1203126e64ed5fa634e32b4eb50 (patch)
treefada261760bf54e725264ba608dbd6f75d48fbc7
parentcb8e752442b17f10215209eabd0bfdf9cb1324d3 (diff)
downloadaur-faadd40bab37a1203126e64ed5fa634e32b4eb50.tar.gz
update with apatch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--audio-item.patch34
3 files changed, 46 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d46055f2f7d9..e29356ef6662 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jul 17 20:38:29 UTC 2016
+# Wed Jul 20 18:33:22 UTC 2016
pkgbase = lilypond-git
pkgdesc = An automated music engraving system (Git snapshot)
- pkgver = 2.19.45.1.25.g47b45b5
+ pkgver = 2.19.45.1.30.g96b15d6
pkgrel = 1
url = http://lilypond.org/
arch = i686
@@ -30,7 +30,9 @@ pkgbase = lilypond-git
conflicts = lilypond-devel
options = !makeflags
source = git://git.sv.gnu.org/lilypond.git
+ source = audio-item.patch
md5sums = SKIP
+ md5sums = 9795811b1d588296e1b483ec107389ea
pkgname = lilypond-git
diff --git a/PKGBUILD b/PKGBUILD
index 561d3af79ad9..ed57cf08f907 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.19.45.1.25.g47b45b5
+pkgver=2.19.45.1.30.g96b15d6
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -20,8 +20,9 @@ optdepends=('imagemagick: building HTML documentation'
'rsync: installing HTML documentation')
provides=('lilypond')
conflicts=('lilypond' 'lilypond-devel')
-source=(git://git.sv.gnu.org/lilypond.git)
-md5sums=('SKIP')
+source=(git://git.sv.gnu.org/lilypond.git audio-item.patch)
+md5sums=('SKIP'
+ '9795811b1d588296e1b483ec107389ea')
options=('!makeflags')
pkgver() {
@@ -42,7 +43,7 @@ prepare() {
sed -i 's|GUILE_LDFLAGS=.*|GUILE_LDFLAGS="`pkg-config --libs guile`"|' configure.ac
rm -rf python/out/
- sed -i '28iusing namespace std;' lily/main.cc
+ patch -p1 < "$srcdir"/audio-item.patch
}
build() {
@@ -51,9 +52,9 @@ build() {
export PYTHON_CONFIG="python2-config"
[ -f config.hh ] && rm config.hh
./autogen.sh \
- --prefix=/usr \
- --disable-documentation \
- --enable-guile2
+ --prefix=/usr \
+ --disable-documentation \
+ --enable-guile2
make all
}
diff --git a/audio-item.patch b/audio-item.patch
new file mode 100644
index 000000000000..9bee3b9233a2
--- /dev/null
+++ b/audio-item.patch
@@ -0,0 +1,34 @@
+diff --git a/lily/audio-item.cc b/lily/audio-item.cc
+index 2c5d691..c5b1f87 100644
+--- a/lily/audio-item.cc
++++ b/lily/audio-item.cc
+@@ -102,9 +102,9 @@ Audio_key::Audio_key (int acc, bool major)
+ major_ = major;
+ }
+
+-const Real Audio_span_dynamic::MINIMUM_VOLUME;
+-const Real Audio_span_dynamic::MAXIMUM_VOLUME;
+-const Real Audio_span_dynamic::DEFAULT_VOLUME;
++constexpr Real Audio_span_dynamic::MINIMUM_VOLUME;
++constexpr Real Audio_span_dynamic::MAXIMUM_VOLUME;
++constexpr Real Audio_span_dynamic::DEFAULT_VOLUME;
+
+ Audio_span_dynamic::Audio_span_dynamic (Moment mom, Real volume)
+ : start_moment_ (mom),
+diff --git a/lily/include/audio-item.hh b/lily/include/audio-item.hh
+index 597fa6a..9a2eea0 100644
+--- a/lily/include/audio-item.hh
++++ b/lily/include/audio-item.hh
+@@ -48,9 +48,9 @@ private:
+ class Audio_span_dynamic : public Audio_element
+ {
+ public:
+- static const Real MINIMUM_VOLUME = 0.0;
+- static const Real MAXIMUM_VOLUME = 1.0;
+- static const Real DEFAULT_VOLUME = 90.0 / 127.0;
++ static constexpr Real MINIMUM_VOLUME = 0.0;
++ static constexpr Real MAXIMUM_VOLUME = 1.0;
++ static constexpr Real DEFAULT_VOLUME = 90.0 / 127.0;
+
+ private:
+ Moment start_moment_;