summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chapuis2016-06-10 10:13:15 +0200
committerPierre Chapuis2016-06-10 10:13:15 +0200
commitfc2cbaa381d7ee74312258bea97a37130b07aa28 (patch)
tree76b011421d85bcfb7fa1234a86f40b16e96cb229
downloadaur-fc2cbaa381d7ee74312258bea97a37130b07aa28.tar.gz
initial commit (1.1.0beta-1)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
-rw-r--r--lima.install11
-rw-r--r--lima.service10
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca43b71d6c0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lima
+ pkgdesc = Personal Cloud software
+ pkgver = 1.1.0beta
+ pkgrel = 1
+ url = https://meetlima.com
+ install = lima.install
+ arch = x86_64
+ license = custom
+ makedepends = prelink
+ depends = python2
+ depends = fuse
+ source = https://static.meetlima.com/linux-client/lima-1.1.0beta-amd64.tgz
+ source = lima.service
+ sha256sums = 1b845f976c127c9abe0f46c51347e9c74afd69a1cda35289f470c861ca92f8db
+ sha256sums = 68662c1437f88403f38b0e80da3b2b546512fe524b791cba27791cd2d5033e7c
+
+pkgname = lima
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3530d9c9b27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Pierre Chapuis <catwell at archlinux dot us>
+
+pkgname=lima
+pkgver=1.1.0beta
+pkgrel=1
+pkgdesc="Personal Cloud software"
+depends=(python2 fuse)
+makedepends=(prelink)
+arch=("x86_64")
+url="https://meetlima.com"
+license=(custom)
+install="lima.install"
+source=(
+ "https://static.meetlima.com/linux-client/$pkgname-$pkgver-amd64.tgz"
+ "lima.service"
+)
+sha256sums=(
+ "1b845f976c127c9abe0f46c51347e9c74afd69a1cda35289f470c861ca92f8db"
+ "68662c1437f88403f38b0e80da3b2b546512fe524b791cba27791cd2d5033e7c"
+)
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ # Copy lib directory.
+ mkdir -p "$pkgdir/usr"
+ cp -r lib "$pkgdir/usr"
+
+ # Use python2 instead of python to make Namcap happy.
+ sed -i -e "s|#!/usr/bin/env python$|#!/usr/bin/env python2|g" \
+ $(find "$pkgdir" -name "*.py")
+
+ # All .pyc files are OK.
+ find "$pkgdir" -name "*.pyc" -exec touch {} \;
+
+ # Mark stack of library as non-executable.
+ execstack -c "$pkgdir/usr/lib/lima/pylima.so"
+
+ # Systemd unit file
+ install -Dm0644 "$srcdir/lima.service" \
+ "$pkgdir/usr/lib/systemd/user/lima.service"
+
+ # Executable and license file
+ install -Dm755 lima "$pkgdir/usr/bin/lima"
+ install -Dm0644 "lib/lima/TAC.txt" \
+ "$pkgdir/usr/lib/licenses/$pkgname/TAC.txt"
+}
diff --git a/lima.install b/lima.install
new file mode 100644
index 000000000000..37a0429638a4
--- /dev/null
+++ b/lima.install
@@ -0,0 +1,11 @@
+post_install () {
+ echo "To start the Lima service, run \`systemctl --user start lima.service\`."
+ echo "To start automatically on login, run \`systemctl --user enable lima.service\`."
+ echo "For more information, run \`lima help\` and \`lima readme\`."
+}
+
+post_remove () {
+ echo "If you intend to purge all Lima user data from your system, please remove the"
+ echo "'~/.local/share/lima' directory. Note that you will lose local files that have"
+ echo "not been uploaded to your Lima yet."
+}
diff --git a/lima.service b/lima.service
new file mode 100644
index 000000000000..5d09b9bd16ad
--- /dev/null
+++ b/lima.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Lima Personal Cloud
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/lima start nobg
+ExecStop=/usr/bin/lima stop
+
+[Install]
+WantedBy=default.target