summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Jester-Pfadt2015-06-02 21:13:56 +0200
committerTim Jester-Pfadt2015-06-02 21:13:56 +0200
commit7db0482c19300fd25f5143cb02b32c405429b6c6 (patch)
tree3e8b20ae14606e3700bac2d97710e03c026e83db
downloadaur-7db0482c19300fd25f5143cb02b32c405429b6c6.tar.gz
Added my own packages, removed foreign ones.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD41
-rw-r--r--sources.list1
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe96b7ad1485
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by makepkg 4.2.1
+# Thu Apr 16 10:16:17 UTC 2015
+pkgbase = limba-git
+ pkgdesc = Limba is a new project which allows 3rd-party software installations on Linux
+ pkgver = 280.c75853a
+ pkgrel = 9
+ url = https://github.com/ximion/limba
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ license = LGPL2.1
+ makedepends = git
+ makedepends = cmake
+ depends = glib2
+ depends = gobject-introspection
+ depends = appstream
+ depends = polkit
+ depends = libarchive
+ depends = gpgme
+ depends = docbook-xsl
+ depends = xmlto
+ depends = curl
+ depends = libutil-linux
+ depends = intltool
+ source = git+https://github.com/ximion/limba.git
+ source = sources.list
+ sha256sums = SKIP
+ sha256sums = 38a9c1d7592f27a19f8815b69365f9f70ca719f7ea3455c10eec9e24801a6570
+
+pkgname = limba-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b287cd33a6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Tim Jester-Pfadt <t.jp<at>gmx.de>
+
+pkgname=limba-git
+pkgver=280.c75853a
+pkgrel=9
+pkgdesc="Limba is a new project which allows 3rd-party software installations on Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/ximion/limba"
+license=('GPLv2' 'LGPL2.1')
+depends=('glib2' 'gobject-introspection' 'appstream' 'polkit' 'libarchive' 'gpgme' 'docbook-xsl' 'xmlto' 'curl' 'libutil-linux' 'intltool')
+makedepends=('git' 'cmake')
+source=('git+https://github.com/ximion/limba.git'
+ 'sources.list')
+sha256sums=('SKIP'
+ '38a9c1d7592f27a19f8815b69365f9f70ca719f7ea3455c10eec9e24801a6570')
+
+build() {
+ cd ${srcdir}/limba
+ if [ -d build ]; then
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+ else
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+ fi
+}
+
+package() {
+ cd "${srcdir}"/limba
+ cd build
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 "${srcdir}"/sources.list "${pkgdir}"/etc/limba/sources.list
+ chmod 700 "${pkgdir}"/usr/share/polkit-1/rules.d/
+}
+
+pkgver() {
+ cd "$srcdir"/limba
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
diff --git a/sources.list b/sources.list
new file mode 100644
index 000000000000..be3f958b7ab9
--- /dev/null
+++ b/sources.list
@@ -0,0 +1 @@
+http://people.freedesktop.org/~mak/stuff/neverball-lirepo/