summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2024-01-02 14:42:07 -0500
committerGuillaume Horel2024-01-02 14:42:07 -0500
commit98a65a7a2da4efc286bf685104e6f70bd54f409c (patch)
tree29a4cd50384e1871f1faae6ce9e4ae57bfd5f52a
parentc2feddd132888e171032654033b9ff2165f9cbdd (diff)
downloadaur-lime.tar.gz
bump to 5.3.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38ed7a5eafe3..8dbc03042083 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = lime
pkgdesc = C++ library implementing Open Whisper System Signal protocol
- pkgver = 5.2.73
+ pkgver = 5.3.5
pkgrel = 1
url = http://www.linphone.org/
arch = x86_64
license = GPL
makedepends = cmake
makedepends = boost
- depends = bctoolbox>=5.2.73
+ depends = bctoolbox>=5.3.5
depends = soci>=4.0.0
- source = lime-5.2.73.tar.gz::https://github.com/BelledonneCommunications/lime/archive/5.2.73.tar.gz
- sha256sums = bea5a2c3d74dd905adade35c1d7f2e79678d0a2212fcd27a922e0c94d61b7ef3
+ source = lime-5.3.5.tar.gz::https://github.com/BelledonneCommunications/lime/archive/5.3.5.tar.gz
+ sha256sums = cb7995485af93298624d66fcfc90653ee5fa0eea125b55fff79260cf2f08a51d
pkgname = lime
diff --git a/PKGBUILD b/PKGBUILD
index fd6eb8d5cfc9..340a3b30588e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=lime
-pkgver=5.2.73
+pkgver=5.3.5
pkgrel=1
pkgdesc="C++ library implementing Open Whisper System Signal protocol"
arch=('x86_64')
@@ -10,13 +10,13 @@ license=('GPL')
depends=("bctoolbox>=$pkgver" 'soci>=4.0.0')
makedepends=('cmake' 'boost')
source=("$pkgname-$pkgver.tar.gz::https://github.com/BelledonneCommunications/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('bea5a2c3d74dd905adade35c1d7f2e79678d0a2212fcd27a922e0c94d61b7ef3')
+sha256sums=('cb7995485af93298624d66fcfc90653ee5fa0eea125b55fff79260cf2f08a51d')
build() {
cmake -B build $pkgname-$pkgver \
-DCMAKE_PREFIX_PATH="/usr" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC="NO" \
+ -DBUILD_SHARED_LIBS=YES \
-DENABLE_UNIT_TESTS=NO \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized" \
-Wno-dev