summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-07-11 19:58:46 +0100
committerFFY002018-07-11 19:58:46 +0100
commite4bf319be6a4339e818a738f21f37794ef7148e1 (patch)
treea3217d5ab613b5312608efac3765bc86fdad4d87
downloadaur-e4bf319be6a4339e818a738f21f37794ef7148e1.tar.gz
pkgbuild: initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..354f8181ed33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lime-tools-git
+ pkgdesc = A collection of useful tools for use with the LimeSDR family of boards
+ pkgver = r11.1ff87a6
+ pkgrel = 1
+ url = https://github.com/myriadrf/lime-tools
+ arch = any
+ license = Apache
+ makedepends = cmake
+ depends = sqlite3
+ depends = wxgtk3
+ depends = opengl-driver
+ depends = libusb>=1.0
+ depends = soapysdr
+ depends = wget
+ provides = lime-tools
+ conflicts = lime-tools
+ source = git+https://github.com/myriadrf/lime-tools
+ sha256sums = SKIP
+
+pkgname = lime-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab0376f4ce96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: FFY00 <filipe.lains@gmail.com>
+pkgname=lime-tools-git
+_pkgname=${pkgname%-git}
+pkgver=r11.1ff87a6
+pkgrel=1
+pkgdesc="A collection of useful tools for use with the LimeSDR family of boards"
+arch=(any)
+url="https://github.com/myriadrf/lime-tools"
+license=('Apache')
+depends=('sqlite3' 'wxgtk3' 'opengl-driver' 'libusb>=1.0' 'soapysdr' 'wget')
+makedepends=('cmake')
+provides=('lime-tools')
+conflicts=('lime-tools')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "$srcdir"/$_pkgname/build
+ cd "$srcdir"/$_pkgname/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$_pkgname/build
+
+ make DESTDIR="$pkgdir" install
+}