summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-04-25 15:17:34 +0100
committerFFY002018-04-25 15:17:34 +0100
commite571a31c5dd8707573d290be54b4eb23f7dad070 (patch)
treebb28106d0de9254cb6a4b5ce03ceb03eb47c5858
parent1374f10acf0f829989e63c0dc9b320564a4bf2fe (diff)
downloadaur-e571a31c5dd8707573d290be54b4eb23f7dad070.tar.gz
pkgbuild: add icon and fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
-rw-r--r--limesuitegui.desktop11
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11c845a8c816..6f6d1d029f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,9 @@ pkgbase = limesuite
conflicts = limesdr
conflicts = soapylms7
source = https://github.com/myriadrf/LimeSuite/archive/v18.04.1.tar.gz
+ source = limesuitegui.desktop
md5sums = 529b6740ef881846ff09318515baf7f0
+ md5sums = 81b3ccb7b942f0dc7e72ae9bb517a3e4
pkgname = limesuite
diff --git a/PKGBUILD b/PKGBUILD
index 2279519fed66..df8aeb48336f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,14 @@ depends=('sqlite3' 'wxgtk3' 'mesa' 'libusb>=1.0' 'soapysdr')
makedepends=('git' 'cmake')
provides=('limesdr' 'soapylms7')
conflicts=('limesdr' 'soapylms7')
-source=("https://github.com/myriadrf/LimeSuite/archive/v$pkgver.tar.gz")
-md5sums=('529b6740ef881846ff09318515baf7f0')
+source=(
+ "https://github.com/myriadrf/LimeSuite/archive/v$pkgver.tar.gz"
+ 'limesuitegui.desktop'
+)
+md5sums=(
+ '529b6740ef881846ff09318515baf7f0'
+ '81b3ccb7b942f0dc7e72ae9bb517a3e4'
+)
build() {
mkdir -p "$srcdir/LimeSuite-$pkgver/build"
@@ -31,6 +37,8 @@ package() {
make DESTDIR="$pkgdir" install
# Install udev rules, changing mode to 666 and ommitting plugdev group
- mkdir -p "${pkgdir}/etc/udev/rules.d"
- sed 's/MODE="660", GROUP="plugdev"/MODE="666"/g' "${srcdir}/${pkgname}/udev-rules/64-limesuite.rules" > "${pkgdir}/etc/udev/rules.d/64-limesuite.rules"
+ mkdir -p "$pkgdir/etc/udev/rules.d"
+ sed 's/MODE="660", GROUP="plugdev"/MODE="666"/g' "$srcdir/LimeSuite-$pkgver/udev-rules/64-limesuite.rules" > "$pkgdir/etc/udev/rules.d/64-limesuite.rules"
+
+ install -Dm 664 "$srcdir/limesuitegui.desktop" "$pkgdir/usr/share/applications/limesuitegui.desktop"
}
diff --git a/limesuitegui.desktop b/limesuitegui.desktop
new file mode 100644
index 000000000000..e24d2fe9ed6a
--- /dev/null
+++ b/limesuitegui.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=LimeSuiteGUI
+GenericName=LimeSuiteGUI
+Comment=Configuration GUI for LimeSuite
+Exec=LimeSuiteGUI
+Icon=modem
+StartupNotify=true
+Type=Application
+Categories=Utility;Electronics;GTK;