summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-09-30 23:33:05 +0100
committerFFY002018-09-30 23:33:05 +0100
commitf179d62f9919893bee63711d5250fa97ae55d32d (patch)
treef9c0dcc1f510c75d64873a48389679f9883b4579
parentadf9a48e792bd285563032869b8d5e9c9b995dba (diff)
downloadaur-f179d62f9919893bee63711d5250fa97ae55d32d.tar.gz
initial release
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD102
2 files changed, 96 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0af44b616aae..96f29c58391d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,30 @@
-# Generated by mksrcinfo v8
-# Fri Feb 17 11:52:23 UTC 2017
pkgbase = limesuite-git
pkgdesc = Driver and GUI for LMS7002M-based SDR platforms (LimeSDR, Novena RF7, etc.)
- pkgver = r1158.6cf8de1
+ pkgver = 18.06.0.r45.02cabfd
pkgrel = 1
url = https://github.com/myriadrf/LimeSuite
- arch = i686
arch = x86_64
- arch = armv7h
license = Apache
makedepends = git
makedepends = cmake
- depends = soapysdr
- depends = libusb>=1.0
- depends = sqlite
- depends = wxgtk
+ makedepends = doxygen
+ makedepends = octave
+ depends = sqlite3
+ depends = wxgtk2
depends = freeglut
- depends = xdg-utils
+ depends = libusb>=1.0
+ depends = soapysdr
+ depends = wget
depends = gnuplot
- depends = python-scipy
- depends = python-matplotlib
- provides = soapylms7
+ depends = glew
+ depends = fltk
+ optdepends = octave: Octave plugin
provides = limesuite
- conflicts = soapylms7
+ provides = soapylms7
conflicts = limesuite
- source = limesuite-git::git+https://github.com/myriadrf/LimeSuite.git
- sha256sums = SKIP
+ conflicts = soapylms7
+ source = git+https://github.com/myriadrf/LimeSuite.git
+ sha512sums = SKIP
pkgname = limesuite-git
diff --git a/PKGBUILD b/PKGBUILD
index 1119f61f5658..c729b13854fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,94 @@
-# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+# Maintainer: FFY00 <filipe.lains@gmail.com>
pkgname=limesuite-git
-pkgver=r1158.6cf8de1
+pkgver=18.06.0.r45.02cabfd
pkgrel=1
-pkgdesc="Driver and GUI for LMS7002M-based SDR platforms (LimeSDR, Novena RF7, etc.)"
-arch=('i686' 'x86_64' 'armv7h')
-url="https://github.com/myriadrf/LimeSuite"
+pkgdesc='Driver and GUI for LMS7002M-based SDR platforms (LimeSDR, Novena RF7, etc.)'
+arch=('x86_64')
+url='https://github.com/myriadrf/LimeSuite'
license=('Apache')
-depends=('soapysdr' 'libusb>=1.0' 'sqlite' 'wxgtk' 'freeglut' 'xdg-utils' 'gnuplot' 'python-scipy' 'python-matplotlib')
-makedepends=('git' 'cmake')
-provides=('soapylms7' 'limesuite')
-conflicts=('soapylms7' 'limesuite')
-source=(${pkgname}::"git+https://github.com/myriadrf/LimeSuite.git")
-sha256sums=('SKIP')
+depends=('sqlite3' 'wxgtk2' 'freeglut' 'libusb>=1.0' 'soapysdr' 'wget' 'gnuplot' 'glew' 'fltk')
+makedepends=('git' 'cmake' 'doxygen' 'octave')
+optdepends=('octave: Octave plugin')
+provides=('limesuite' 'soapylms7')
+conflicts=('limesuite' 'soapylms7')
+source=("git+$url.git")
+sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd LimeSuite
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
+}
+
+prepare() {
+ cd LimeSuite
+
+ # Change mode to 666 and ommit plugdev group
+ sed -i 's|MODE="660", GROUP="plugdev"|MODE="666"|g' udev-rules/64-limesuite.rules
+
+# # Octave plugin
+# sed -i 's|/usr/local|/usr|g' octave/Makefile # Fix install directory
+# cp src/lime/* octave/ # Fix headers
}
build() {
- cd "${srcdir}/${pkgname}"
- mkdir -p build && cd build
- cmake ../ -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
- make -j4
+ mkdir -p LimeSuite/build
+ cd LimeSuite/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_UTILITIES=True \
+ -DENABLE_LIME_UTIL=True \
+ -DENABLE_DESKTOP=True \
+ -DENABLE_SOAPY_LMS7=True \
+ -DENABLE_EVB7COM=True \
+ -DENABLE_PCIE_XILLYBUS=True \
+ -DENABLE_REMOTE=True \
+ -DENABLE_QUICKTEST=True \
+ -DENABLE_MCU_TESTBENCH=True \
+ -DENABLE_FTDI=True \
+ -DENABLE_FX3=True \
+ -DENABLE_STREAM_UNITE=True \
+ -DENABLE_EXAMPLES=True \
+ -DENABLE_HEADERS=True \
+ -DENABLE_GUI=True \
+ -DENABLE_API_DOXYGEN=True \
+ -DLIME_SUITE_EXTVER=$pkgver
+
+# -DENABLE_TESTS=True \
+# -DENABLE_NOVENARF7=True \
+
+ make
+
+# # Octave plugin
+# cd ../octave
+#
+# make
}
+#check() {
+# # Octave plugin
+# cd LimeSuite/octave
+#
+# make test
+#}
+
package() {
- make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
- # Install udev rules, changing mode to 666 and ommitting plugdev group
- mkdir -p "${pkgdir}/etc/udev/rules.d"
- sed 's/MODE="660", GROUP="plugdev"/MODE="666"/g' "${srcdir}/${pkgname}/udev-rules/64-limesuite.rules" > "${pkgdir}/etc/udev/rules.d/64-limesuite.rules"
+ cd LimeSuite/build
+
+ make DESTDIR="$pkgdir" install
+
+ # Install udev rules, changing mode to 666 and ommitting plugdev group
+ install -Dm 644 ../udev-rules/64-limesuite.rules "$pkgdir"/etc/udev/rules.d/64-limesuite.rules
+
+ # Install icons and .desktop file
+ install -Dm 644 ../Desktop/lime-suite-128.png "$pkgdir"/usr/share/pixmaps/lime-suite.png
+ install -Dm 755 ../Desktop/lime-suite.desktop "$pkgdir"/usr/share/applications/lime-suite.desktop
+
+ # Install documentation
+ install -dm 755 "$pkgdir"/usr/share/doc/$pkgname
+ cp -r --no-preserve=ownership ../docs/LMS_API_Documentation/* "$pkgdir"/usr/share/doc/$pkgname
}
+