summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMawcomW2015-06-15 23:31:40 -0300
committerMawcomW2015-06-15 23:31:40 -0300
commit53e4d7a6b5732c9838ab1f6527ff08f1d42d2045 (patch)
tree1c03f68671a3b53cdde8fe4a12f27a108ddcd4dd
downloadaur-53e4d7a6b5732c9838ab1f6527ff08f1d42d2045.tar.gz
Initial import.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD73
-rw-r--r--apache.example.conf22
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..399fc814eb5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = limesurvey
+ pkgdesc = Then open source survey application.
+ pkgver = 2.0.6.150612
+ pkgrel = 1
+ url = http://www.limesurvey.org
+ arch = any
+ license = GPL2
+ depends = php>=5.3
+ optdepends = apache: a supported application server
+ optdepends = nginx: a supported application server
+ optdepends = tomcat6: a supported application server
+ optdepends = tomcat7: a supported application server
+ optdepends = mariadb: MariaDB database support
+ optdepends = mysql: MySQL database support
+ optdepends = postgresql: PostgreSQL database support
+ provides = limesurvey
+ source = http://download.limesurvey.org/latest-stable-release/limesurvey206plus-build150612.tar.gz
+ source = apache.example.conf
+ sha512sums = 24a68fde6a2df71a329974f41f1f96a480302e970d08cafee148992c15c22f2387c8cae3de71ab346ce21eb234bf9dfe15777c3cc2eac1589bbb1c3611eeb3ed
+ sha512sums = e594a3a02cb04e1cca9ddf1c5995344f20adc9c5543fe622ad66fdc48d587fc969541530f1e2a8883e0f501ed1b2d409c23ecc7cd8e29aaea0369f625cd4f417
+
+pkgname = limesurvey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04401f9e74e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: mawcomw <mawcomw@gmail.com>
+pkgname=limesurvey
+pkgver=2.0.6.150612
+pkgrel=1
+pkgdesc="Then open source survey application."
+arch=('any')
+url="http://www.limesurvey.org"
+license=('GPL2')
+depends=('php>=5.3')
+#makedepends=()
+#checkdepends=()
+optdepends=('apache: a supported application server'
+ 'nginx: a supported application server'
+ 'tomcat6: a supported application server'
+ 'tomcat7: a supported application server'
+ 'mariadb: MariaDB database support'
+ 'mysql: MySQL database support'
+ 'postgresql: PostgreSQL database support')
+provides=('limesurvey')
+#conflicts=()
+#replaces=()
+#backup=('usr/share/webapps/redmine/config/configuration.yml'
+# 'usr/share/webapps/redmine/config/database.yml')
+#options=()
+#install=limesurvey.install
+#changelog
+source=('http://download.limesurvey.org/latest-stable-release/limesurvey206plus-build150612.tar.gz'
+ 'apache.example.conf')
+#noextract
+#md5sums=()
+#sha1sums=()
+#sha256sums=()
+#sha384sums=()
+sha512sums=('24a68fde6a2df71a329974f41f1f96a480302e970d08cafee148992c15c22f2387c8cae3de71ab346ce21eb234bf9dfe15777c3cc2eac1589bbb1c3611eeb3ed'
+ 'e594a3a02cb04e1cca9ddf1c5995344f20adc9c5543fe622ad66fdc48d587fc969541530f1e2a8883e0f501ed1b2d409c23ecc7cd8e29aaea0369f625cd4f417')
+
+build() {
+ return 0
+}
+
+package() {
+ _limesurvey_installation_path="/usr/share/webapps"
+ _limesurvey_conf_path="/etc/webapps"
+
+ _instdir="$pkgdir/${_limesurvey_installation_path}"
+ _conf_dir="$pkgdir/${_limesurvey_conf_path}"
+
+ #install license
+ install -Dm644 "${srcdir}/${pkgname}/docs/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+
+ # install core application in /usr/share/webapps
+ mkdir -p ${_instdir}
+ cp -ra "${srcdir}/${pkgname}" ${_instdir}
+
+ # install configuration files in /etc/webapps
+ mkdir -p "${_conf_dir}/${pkgname}"
+ # limesurvey does not work with separate paths, and
+ # for now i will not fix this.
+ #mv "${_instdir}/${pkgname}/application/config" "${_conf_dir}/${pkgname}/config"
+ #ln -s "/etc/webapps/${pkgname}/config" "${_instdir}/${pkgname}/application/config"
+
+ # set the group that will run the http server to have write permission (for apache it should be http)
+ chgrp -R http "${_instdir}/${pkgname}/tmp"
+ chmod -R 775 "${_instdir}/${pkgname}/tmp"
+ chgrp -R http "${_instdir}/${pkgname}/upload"
+ chmod -R 775 "${_instdir}/${pkgname}/upload"
+
+ chgrp -R http "${_instdir}/${pkgname}/application/config"
+ chmod -R 775 "${_instdir}/${pkgname}/application/config"
+
+ # install apache example config file
+ install -m 644 ${srcdir}/apache.example.conf ${pkgdir}/etc/webapps/${pkgname}
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..2e633020cdda
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,22 @@
+# If you want to use a subpath instead of a subdomain, uncomment the
+# lines bellow and remember to change the example configuration
+# to meet your needs.
+
+#<IfModule mod_alias.c>
+# Alias /limesurvey /usr/share/webapps/limesurvey/
+#</IfModule>
+
+<VirtualHost *:80>
+ ServerAdmin foo@example.com
+ DocumentRoot /usr/share/webapps/limesurvey
+ ServerName limesurvey.example.com
+ ErrorLog /var/log/httpd/limesurvey.example.info-error_log
+ CustomLog /var/log/httpd/limesurvey.example.info-access_log common
+</VirtualHost>
+
+<Directory /usr/share/webapps/limesurvey/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/limesurvey/:/etc/webapps/limesurvey"
+</Directory>