summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2020-02-11 17:20:00 +0800
committerLin UX2020-02-11 17:20:00 +0800
commit241470cbc7c14a12065ec684afa48072fb11b4ca (patch)
tree7bb905e0df02feba3ad398b6da4667dea651cab0
parentcf4de025826c2d14fb73644488421209301394e5 (diff)
downloadaur-241470cbc7c14a12065ec684afa48072fb11b4ca.tar.gz
Upstream had dropped python2 support
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
2 files changed, 41 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25c85b93968b..080f899c444a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,27 @@
pkgbase = limnoria
pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features
- pkgver = 20190223
+ pkgver = 20200131
pkgrel = 1
url = https://github.com/ProgVal/Limnoria
arch = any
license = 3-clause BSD
makedepends = git
- depends = python2
- optdepends = python2-charade: Detect page's encoding
- optdepends = python2-pytz: Enable Time plugin to calculate the time in specified timezone
- optdepends = python2-dateutil: Enable Time plugin to parse the input time string
- optdepends = python2-gnupg: GnuPG support
- optdepends = python2-feedparser: RSS plugin support
- optdepends = python2-socksipy-branch: SOCKS proxy support
- optdepends = python2-ecdsa: ECDSA support
+ depends = python>=3.4
+ optdepends = python-charade: Detect page's encoding
+ optdepends = python-pytz: Enable Time plugin to calculate the time in specified timezone
+ optdepends = python-dateutil: Enable Time plugin to parse the input time string
+ optdepends = python-gnupg: GnuPG support
+ optdepends = python-feedparser: RSS plugin support
+ optdepends = python-sqlalchemy: Aka plugin support
+ optdepends = python-socksipy-branch: SOCKS proxy support
+ optdepends = python-mock: For testing only
+ optdepends = python-cryptography: ECDSA support
conflicts = limnoria-git
- source = https://github.com/ProgVal/Limnoria/archive/master-2019-02-23.tar.gz
- md5sums = 8632b454f0132ed6c527189e799d9f4e
+ conflicts = limnoria-python3-git
+ source = https://github.com/ProgVal/Limnoria/archive/master-2020-01-31.tar.gz
+ md5sums = f196ca8f5aa016fe99e761c3c19d1116
pkgname = limnoria
+pkgname = limnoria-python3
+
diff --git a/PKGBUILD b/PKGBUILD
index dd5bc3fb6447..f13f570e1fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,43 @@
# Maintainer: Cravix < dr dot neemous at gmail dot com >
-pkgname=limnoria
+pkgbase=limnoria
+pkgname=("limnoria" "limnoria-python3")
_pkgname=Limnoria
-pkgver=20190223
-_pkgver=2019-02-23
+pkgver=20200131
+_pkgver=2020-01-31
pkgrel=1
pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features"
arch=('any')
url="https://github.com/ProgVal/Limnoria"
license=('3-clause BSD')
-depends=('python2')
+depends=('python>=3.4')
makedepends=('git')
-optdepends=("python2-charade: Detect page's encoding"
- "python2-pytz: Enable Time plugin to calculate the time in specified timezone"
- "python2-dateutil: Enable Time plugin to parse the input time string"
- "python2-gnupg: GnuPG support"
- "python2-feedparser: RSS plugin support"
- #"python2-sqlalchemy: Alternative DB engine when no SQLite3 engine installed"
- # But SQLite module has already been integrated into python package, so it doesn't matter
- "python2-socksipy-branch: SOCKS proxy support"
- #"python2-mock: For testing only"
- "python2-ecdsa: ECDSA support")
-conflicts=('limnoria-git')
-source=("https://github.com/ProgVal/${_pkgname}/archive/master-${_pkgver}.tar.gz")
-md5sums=('8632b454f0132ed6c527189e799d9f4e')
+optdepends=("python-charade: Detect page's encoding"
+ "python-pytz: Enable Time plugin to calculate the time in specified timezone"
+ "python-dateutil: Enable Time plugin to parse the input time string"
+ "python-gnupg: GnuPG support"
+ "python-feedparser: RSS plugin support"
+ "python-sqlalchemy: Aka plugin support"
+ "python-socksipy-branch: SOCKS proxy support"
+ "python-mock: For testing only"
+ "python-cryptography: ECDSA support")
+conflicts=('limnoria-git' 'limnoria-python3-git')
+source=("https://github.com/ProgVal/Limnoria/archive/master-${_pkgver}.tar.gz")
+md5sums=('f196ca8f5aa016fe99e761c3c19d1116')
build() {
cd "$srcdir/$_pkgname-master-${_pkgver}"
- python2 setup.py build
+ python3 setup.py build
}
-package() {
+package_limnoria() {
cd "$srcdir/$_pkgname-master-${_pkgver}"
- python2 setup.py install --root="$pkgdir" || return 1
+ python3 setup.py install --root="$pkgdir" || return 1
+}
+
+package_limnoria-python3() {
+ msg2 "This package contains nothing and is for migration only,"
+ msg2 "and will be removed in next month."
}