summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2018-08-15 21:42:09 +0800
committerLin UX2018-08-15 21:42:09 +0800
commite1984f4f2ab883746c74c0175bbe3604b30b7903 (patch)
tree73849a0f4a00c98663a0c127748109ddf4151d9a
downloadaur-e1984f4f2ab883746c74c0175bbe3604b30b7903.tar.gz
Release channel pacakge, reminds me of the good old days.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..248dcd46fe78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = limnoria
+ pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)
+ pkgver = 20180625.2
+ pkgrel = 1
+ url = https://github.com/ProgVal/Limnoria
+ arch = any
+ license = 3-clause BSD
+ makedepends = git
+ depends = python2
+ optdepends = python2-charade: Detect page's encoding
+ optdepends = python2-pytz: Enable Time plugin to calculate the time in specified timezone
+ optdepends = python2-dateutil: Enable Time plugin to parse the input time string
+ optdepends = python2-gnupg: GnuPG support
+ optdepends = python2-feedparser: RSS plugin support
+ optdepends = python2-socksipy-branch: SOCKS proxy support
+ optdepends = python2-ecdsa: ECDSA support
+ source = https://github.com/ProgVal/Limnoria/archive/master-2018-06-25-2.tar.gz
+ md5sums = 71ccd3004ddfb8a7bca7114cab40bb72
+
+pkgname = limnoria
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29180bbe4f77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Cravix < dr dot neemous at gmail dot com >
+
+pkgname=limnoria
+_pkgname=Limnoria
+pkgver=20180625.2
+_pkgver=2018-06-25-2
+pkgrel=1
+pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)"
+arch=('any')
+url="https://github.com/ProgVal/Limnoria"
+license=('3-clause BSD')
+depends=('python2')
+makedepends=('git')
+optdepends=("python2-charade: Detect page's encoding"
+ "python2-pytz: Enable Time plugin to calculate the time in specified timezone"
+ "python2-dateutil: Enable Time plugin to parse the input time string"
+ "python2-gnupg: GnuPG support"
+ "python2-feedparser: RSS plugin support"
+ #"python2-sqlalchemy: Alternative DB engine when no SQLite3 engine installed"
+ # But SQLite module has already been integrated into python package, so it doesn't matter
+ "python2-socksipy-branch: SOCKS proxy support"
+ #"python2-mock: For testing only"
+ "python2-ecdsa: ECDSA support")
+source=("https://github.com/ProgVal/${_pkgname}/archive/master-${_pkgver}.tar.gz")
+md5sums=('71ccd3004ddfb8a7bca7114cab40bb72')
+
+build() {
+ cd "$srcdir/$_pkgname-master-${_pkgver}"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-master-${_pkgver}"
+
+ python2 setup.py install --root="$pkgdir" || return 1
+}