summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2020-03-17 17:11:53 +0800
committerLin UX2020-03-17 17:11:53 +0800
commit629555787b9f33aefdc90039c8b8e095ab5b399c (patch)
treeafaa30dfb0fdc1179aa2aed0030de699ab57c8df
parentf3f01f6e30cc66310154a7a339c2d0c757d3b8eb (diff)
downloadaur-629555787b9f33aefdc90039c8b8e095ab5b399c.tar.gz
Fix build, and end transition
-rw-r--r--.SRCINFO8
-rw-r--r--.install11
-rw-r--r--PKGBUILD23
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e74c439cbf83..312071eefc8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = limnoria-git
pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)
- pkgver = 20200211
- pkgrel = 2
+ pkgver = 20200131.11218.2f493625
+ pkgrel = 1
url = https://github.com/ProgVal/Limnoria
+ install = .install
arch = any
license = 3-clause BSD
makedepends = git
@@ -18,10 +19,9 @@ pkgbase = limnoria-git
optdepends = python-cryptography: ECDSA support
conflicts = limnoria
conflicts = limnoria-python3
+ conflicts = limnoria-python3-git
source = git://github.com/ProgVal/Limnoria.git
md5sums = SKIP
pkgname = limnoria-git
-pkgname = limnoria-python3-git
-
diff --git a/.install b/.install
new file mode 100644
index 000000000000..b704ca567fe0
--- /dev/null
+++ b/.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Notice: Since limnoria now only supports python3, "
+ echo "Original executive supybot3 in limnoria-python3(-git)"
+ echo "has been replaced by supybot."
+}
+
+post_upgrade() {
+ echo "Notice: Since limnoria now only supports python3, "
+ echo " Original executive supybot3 in limnoria-python3(-git)"
+ echo " has been replaced by supybot, same goes for other executives."
+}
diff --git a/PKGBUILD b/PKGBUILD
index 59cf92eccfe7..a08cbf8a9b61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Cravix < dr dot neemous at gmail dot com >
-pkgbase=limnoria-git
-pkgname=("limnoria-git" "limnoria-python3-git")
+pkgname=limnoria-git
_pkgname=Limnoria
-pkgver=20200211
-pkgrel=2
+pkgver=20200131.11218.2f493625
+pkgrel=1
pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)"
arch=('any')
url="https://github.com/ProgVal/Limnoria"
@@ -20,14 +19,17 @@ optdepends=("python-charade: Detect page's encoding"
"python-pysocks: SOCKS proxy support"
"python-mock: For testing only"
"python-cryptography: ECDSA support")
-conflicts=('limnoria' 'limnoria-python3')
+conflicts=('limnoria' 'limnoria-python3' 'limnoria-python3-git')
source=("git://github.com/ProgVal/$_pkgname.git")
md5sums=('SKIP')
+install=".install"
pkgver() {
cd "${srcdir}/${_pkgname}"
-
- sed -n '1s/[^[:digit:]]//gp' src/version.py
+ timestamp="$(git log -n1 --format="%at")"
+ maj="$(date +"%Y%m%d" --date="@${timestamp}" -u)"
+ min="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ echo "${maj}.${min}"
}
build() {
@@ -36,13 +38,8 @@ build() {
python3 setup.py build
}
-package_limnoria-git() {
+package() {
cd "$srcdir/$_pkgname"
python3 setup.py install --root="$pkgdir" || return 1
}
-
-package_limnoria-python3-git() {
- msg "This package contains nothing and is only for migration,"
- msg "and will be removed in next release."
-}