summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin2015-06-16 21:26:19 +0800
committerLin2015-06-16 21:26:19 +0800
commitc9a5f89ab4a5af364b39820443860e475119ff7b (patch)
tree31c6cbb13213da93db9f492ce850295b5bf78e27
downloadaur-c9a5f89ab4a5af364b39820443860e475119ff7b.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..306b04edc347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = limnoria-git
+ pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)
+ pkgver = 0.83.4.1.10347.530c246
+ pkgrel = 1
+ url = https://github.com/ProgVal/Limnoria
+ arch = any
+ license = 3-clause BSD
+ makedepends = git
+ depends = python2
+ optdepends = python2-charade: Detect page's encoding
+ optdepends = python2-pytz: Enable Time plugin to calculate the time in specified timezone
+ optdepends = python2-dateutil: Enable Time plugin to parse the input time string
+ optdepends = python2-gnupg: GnuPG support
+ optdepends = python2-feedparser: RSS plugin support
+ optdepends = python2-socksipy-branch: SOCKS proxy support
+ optdepends = python2-ecdsa: ECDSA support
+ source = git://github.com/ProgVal/Limnoria.git
+ md5sums = SKIP
+
+pkgname = limnoria-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..396844c7e314
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Cravix < dr dot neemous at gmail dot com >
+
+pkgname=limnoria-git
+_pkgname=Limnoria
+pkgver=0.83.4.1.10347.530c246
+pkgrel=1
+pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)"
+arch=('any')
+url="https://github.com/ProgVal/Limnoria"
+license=('3-clause BSD')
+depends=('python2')
+makedepends=('git')
+optdepends=("python2-charade: Detect page's encoding"
+ "python2-pytz: Enable Time plugin to calculate the time in specified timezone"
+ "python2-dateutil: Enable Time plugin to parse the input time string"
+ "python2-gnupg: GnuPG support"
+ "python2-feedparser: RSS plugin support"
+ #"python2-sqlalchemy: Alternative DB engine when no SQLite3 engine installed"
+ # But SQLite module has already been integrated into python package, so it doesn't matter
+ "python2-socksipy-branch: SOCKS proxy support"
+ #"python2-mock: For testing only"
+ "python2-ecdsa: ECDSA support")
+source=("git://github.com/ProgVal/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ echo $(awk -F"['+]" '/% version/ {print $2}' ./setup.py).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ python2 setup.py install --root="$pkgdir" || return 1
+}