summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2018-08-15 21:38:14 +0800
committerLin UX2018-08-15 21:38:14 +0800
commitc06ed043e90d5d871d205dc3da8d893d234246b8 (patch)
tree49f3bde9874ef5c8ab930e98d150a22807215e44
downloadaur-c06ed043e90d5d871d205dc3da8d893d234246b8.tar.gz
Release channel pacakge, reminds me of the good old days.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..433101f47071
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = limnoria-python3
+ pkgdesc = An IRC bot based on Supybot, with sqlite3 support and other features
+ pkgver = 20180625.2
+ pkgrel = 1
+ url = https://github.com/ProgVal/Limnoria
+ arch = any
+ license = 3-clause BSD
+ makedepends = git
+ depends = python
+ optdepends = python-charade: Detect page's encoding
+ optdepends = python-pytz: Enable Time plugin to calculate the time in specified timezone
+ optdepends = python-dateutil: Enable Time plugin to parse the input time string
+ optdepends = python-gnupg: GnuPG support
+ optdepends = python-feedparser: RSS plugin support
+ optdepends = python-ecdsa: ECDSA support
+ source = https://github.com/ProgVal/Limnoria/archive/master-2018-06-25-2.tar.gz
+ md5sums = SKIP
+
+pkgname = limnoria-python3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d52a993d018
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Cravix < dr dot neemous at gmail dot com >
+
+pkgname=limnoria-python3
+_pkgname=Limnoria
+pkgver=20180625.2
+_pkgver=2018-06-25-2
+pkgrel=1
+pkgdesc="An IRC bot based on Supybot, with sqlite3 support and other features"
+arch=('any')
+url="https://github.com/ProgVal/Limnoria"
+license=('3-clause BSD')
+depends=('python')
+makedepends=('git')
+optdepends=("python-charade: Detect page's encoding"
+ "python-pytz: Enable Time plugin to calculate the time in specified timezone"
+ "python-dateutil: Enable Time plugin to parse the input time string"
+ "python-gnupg: GnuPG support"
+ "python-feedparser: RSS plugin support"
+ #"python-sqlalchemy: Alternative DB engine when no SQLite3 engine installed"
+ # But SQLite module has already been integrated into python package, so it doesn't matter
+ #"python-mock: For testing only"
+ "python-ecdsa: ECDSA support")
+source=("https://github.com/ProgVal/Limnoria/archive/master-${_pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname-master-${_pkgver}"
+
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-master-${_pkgver}"
+
+ python3 setup.py install --root="$pkgdir" || return 1
+
+ cd "$pkgdir/usr"
+ rename "supybot" "supybot3" ./share/man/man1/* ./bin/*
+}