summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzfo2016-05-24 22:32:34 +0200
committerzfo2016-05-24 22:32:34 +0200
commiteb5d4a246d9b3f26a70de8aaa7ae234bebc3ba68 (patch)
treefdad4cee7e778b43f23ed4dfacc068946d9449eb
downloadaur-eb5d4a246d9b3f26a70de8aaa7ae234bebc3ba68.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83492270de16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue May 24 20:32:34 UTC 2016
+pkgbase = linenoise
+ pkgdesc = A small self-contained alternative to readline and libedit
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/antirez/linenoise
+ arch = i686
+ arch = x86_64
+ license = BSD
+ source = https://github.com/antirez/linenoise/archive/1.0.tar.gz
+ md5sums = 57c163f6e53bdb5b8f935cafb714ab16
+
+pkgname = linenoise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..769ee0cbb035
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: zfo <zfoofz1 at gmail dot com>
+
+pkgname=linenoise
+pkgver=1.0
+pkgrel=1
+pkgdesc="A small self-contained alternative to readline and libedit"
+arch=('i686' 'x86_64')
+url="https://github.com/antirez/linenoise"
+license=('BSD')
+depends=()
+source=("https://github.com/antirez/linenoise/archive/$pkgver.tar.gz")
+md5sums=('57c163f6e53bdb5b8f935cafb714ab16')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cc -shared -fPIC linenoise.c -o liblinenoise.so
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m644 ./liblinenoise.so $pkgdir/usr/lib/liblinenoise.so
+}