summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-07-28 16:47:30 +0200
committerhaawda2019-07-28 16:47:30 +0200
commit0233283ec2e51c827fcd6bdd0e863629c622abf6 (patch)
treebad4c0abe8b7ca5ed1d09fe8e047f22557fc906d
downloadaur-0233283ec2e51c827fcd6bdd0e863629c622abf6.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86bbb72d3b2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = link-grammar-git
+ pkgdesc = A Grammar Checking library
+ pkgver = 5.6.2.r114.g91d17a72
+ pkgrel = 1
+ url = http://www.abisource.com/projects/link-grammar/
+ arch = x86_64
+ license = LGPL
+ makedepends = swig
+ makedepends = flex
+ makedepends = graphviz
+ makedepends = python
+ makedepends = python2
+ depends = hunspell
+ depends = sqlite
+ depends = libedit
+ depends = pcre2
+ depends = java-runtime
+ provides = link-grammar
+ conflicts = link-grammar
+ source = git+https://github.com/opencog/link-grammar
+ md5sums = SKIP
+
+pkgname = link-grammar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a9963cc7fe1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=link-grammar-git
+pkgver=5.6.2.r114.g91d17a72
+pkgrel=1
+pkgdesc="A Grammar Checking library"
+arch=('x86_64')
+url="http://www.abisource.com/projects/link-grammar/"
+license=('LGPL')
+depends=('hunspell' 'sqlite' 'libedit' 'pcre2' 'java-runtime')
+makedepends=('swig' 'flex' 'graphviz' 'python' 'python2')
+conflicts=('link-grammar')
+provides=('link-grammar')
+source=("git+https://github.com/opencog/link-grammar")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags | cut -c14- | sed 's+-+.r+' | tr - .
+}
+
+build() {
+ cd ${pkgname%-git}
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-python-bindings
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR="${pkgdir}" install
+}