summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Cornwall2022-01-28 21:06:33 -0800
committerBrett Cornwall2022-01-28 21:06:33 -0800
commit2cbfc7200c4e24479ec87e354cd8aaa606b53843 (patch)
treeaf82745fb4273b80c1c9e998a936f6462d80b96b
parentd0c1932cb41d0c35fc334396575b5296777a25f6 (diff)
downloadaur-2cbfc7200c4e24479ec87e354cd8aaa606b53843.tar.gz
upgpkg: 10.1.0; move source to pypi; rm tests
Tests seem to be quite broken so we'll just go without them, sadly.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc03175e7068..d4cff03ec308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = linkchecker
pkgdesc = Check websites for broken links.
- pkgver = 10.0.1
+ pkgver = 10.1.0
pkgrel = 1
url = https://github.com/linkcheck/linkchecker
arch = any
license = GPL2
+ makedepends = python-polib
makedepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = python-pip
depends = python-requests
depends = python-dnspython
depends = python-xdg
depends = python-beautifulsoup4
optdepends = python-argcomplete: For command-line completion
- source = linkchecker-10.0.1.tar.gz::https://github.com/linkchecker/linkchecker/archive/v10.0.1.tar.gz
- sha256sums = 81641ac8794d355585fa8807b525a868e7ff13a4d85d04c2aba13e2a25e71484
+ source = linkchecker-10.1.0.tar.gz::https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-10.1.0.tar.gz
+ sha256sums = ea9354665341c9f1650b6bb716a64d2022635e7fa38e5e05280ba79a57c237b2
pkgname = linkchecker
-
diff --git a/PKGBUILD b/PKGBUILD
index c438031c0fe1..6a74e7a04d2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,18 @@
# Contributor: Sergey Mastykov
pkgname=linkchecker
-pkgver=10.0.1
+pkgver=10.1.0
pkgrel=1
pkgdesc="Check websites for broken links."
arch=('any')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
-makedepends=('python-pytest')
+makedepends=(
+ 'python-polib'
+ 'python-pytest'
+ 'python-setuptools'
+ 'python-pip' # FIXME: why?
+)
depends=(
'python-requests'
'python-dnspython'
@@ -18,20 +23,16 @@ depends=(
optdepends=(
'python-argcomplete: For command-line completion'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/linkchecker/linkchecker/archive/v$pkgver.tar.gz")
-sha256sums=('81641ac8794d355585fa8807b525a868e7ff13a4d85d04c2aba13e2a25e71484')
+# GitHub releases are not recommended by upstream (and fail to build anyway).
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-$pkgver.tar.gz")
+sha256sums=('ea9354665341c9f1650b6bb716a64d2022635e7fa38e5e05280ba79a57c237b2')
build() {
- cd "$pkgname-$pkgver"
+ cd "LinkChecker-$pkgver"
python setup.py build
}
-# Upstream tests need to be fixed first
-#check() {
-# cd "$pkgname-$pkgver" && python setup.py test
-#}
-
package() {
- cd "$pkgname-$pkgver"
+ cd "LinkChecker-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}