summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-12-05 23:30:42 +0100
committerMarco Rubin2022-12-05 23:30:42 +0100
commit3aae5d80940cd2233620c496989868c63aaf42b3 (patch)
tree6b92213d748f149211e6bfe33fd5ff03e7f54ec5
parentbeaf33df6cd273eaa2537386b7d99b02aaf9f3e6 (diff)
downloadaur-3aae5d80940cd2233620c496989868c63aaf42b3.tar.gz
10.2.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c8091bc9401..1ec6827782ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = linkchecker
pkgdesc = check links in web documents or full websites
- pkgver = 10.2.0
- pkgrel = 2
+ pkgver = 10.2.1
+ pkgrel = 1
url = https://github.com/linkcheck/linkchecker
arch = any
license = GPL2
makedepends = python-hatch-vcs
- makedepends = python-hatchling
+ makedepends = python-hatchling>=1.8.0
makedepends = python-installer
makedepends = python-polib
- depends = python-beautifulsoup4
- depends = python-dnspython
- depends = python-requests
+ depends = python>=3.7
+ depends = python-beautifulsoup4>=4.8.1
+ depends = python-dnspython>=2.0
+ depends = python-requests>=2.20
optdepends = python-argcomplete: For command-line completion
- source = https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-10.2.0.tar.gz
- sha256sums = 943a3f3f30279fbb85fc6f0569d808cf1ae4be0de4c2050c6f713429b8e58b59
+ source = https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-10.2.1.tar.gz
+ b2sums = ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549
pkgname = linkchecker
diff --git a/PKGBUILD b/PKGBUILD
index 3b953e5e3cce..60eb3fcdb033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
_name=LinkChecker
pkgname=linkchecker
-pkgver=10.2.0
-pkgrel=2
+pkgver=10.2.1
+pkgrel=1
pkgdesc="check links in web documents or full websites"
arch=('any')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
-depends=('python-beautifulsoup4' 'python-dnspython' 'python-requests')
-makedepends=('python-hatch-vcs' 'python-hatchling' 'python-installer' 'python-polib')
+depends=('python>=3.7' 'python-beautifulsoup4>=4.8.1' 'python-dnspython>=2.0' 'python-requests>=2.20')
+makedepends=('python-hatch-vcs' 'python-hatchling>=1.8.0' 'python-installer' 'python-polib')
optdepends=('python-argcomplete: For command-line completion')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('943a3f3f30279fbb85fc6f0569d808cf1ae4be0de4c2050c6f713429b8e58b59')
+b2sums=('ddbf22d9cdd04d89257b92d032cff24e4dde866b4be115f7b5b878bf2a42dd08159eef451b33ed621d747f06dffa445f4258975b932e5ae0eb8b79cfb8203549')
build() {
cd $pkgname-$pkgver
@@ -24,5 +24,4 @@ build() {
package() {
cd $pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}