summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-12-01 18:04:15 +0100
committerMarco Rubin2022-12-01 18:04:15 +0100
commit9580574b9723083ffc0546dbd546a847b23ee86a (patch)
treec5a93abdec385a8cd19e0dd4d10c87c53c65ea67
parent2cbfc7200c4e24479ec87e354cd8aaa606b53843 (diff)
downloadaur-9580574b9723083ffc0546dbd546a847b23ee86a.tar.gz
10.2.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 23 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4cff03ec308..ccf87852636d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = linkchecker
- pkgdesc = Check websites for broken links.
- pkgver = 10.1.0
+ pkgdesc = check links in web documents or full websites
+ pkgver = 10.2.0
pkgrel = 1
url = https://github.com/linkcheck/linkchecker
arch = any
license = GPL2
+ makedepends = python-hatch-vcs
+ makedepends = python-hatchling
+ makedepends = python-installer
makedepends = python-polib
- makedepends = python-pytest
- makedepends = python-setuptools
- makedepends = python-pip
- depends = python-requests
- depends = python-dnspython
- depends = python-xdg
depends = python-beautifulsoup4
+ depends = python-dnspython
+ depends = python-requests
optdepends = python-argcomplete: For command-line completion
- source = linkchecker-10.1.0.tar.gz::https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-10.1.0.tar.gz
- sha256sums = ea9354665341c9f1650b6bb716a64d2022635e7fa38e5e05280ba79a57c237b2
+ source = https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-10.2.0.tar.gz
+ sha256sums = 943a3f3f30279fbb85fc6f0569d808cf1ae4be0de4c2050c6f713429b8e58b59
pkgname = linkchecker
diff --git a/PKGBUILD b/PKGBUILD
index 6a74e7a04d2a..1495c21a3cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
-# Maintainer: Brett Cornwall <ainola@archlinux.org>
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+# Contributor: Brett Cornwall <ainola@archlinux.org>
# Contributor: Sergey Mastykov
+_name=LinkChecker
pkgname=linkchecker
-pkgver=10.1.0
+pkgver=10.2.0
pkgrel=1
-pkgdesc="Check websites for broken links."
+pkgdesc="check links in web documents or full websites"
arch=('any')
url="https://github.com/linkcheck/linkchecker"
license=('GPL2')
-makedepends=(
- 'python-polib'
- 'python-pytest'
- 'python-setuptools'
- 'python-pip' # FIXME: why?
-)
-depends=(
- 'python-requests'
- 'python-dnspython'
- 'python-xdg'
- 'python-beautifulsoup4'
-)
-optdepends=(
- 'python-argcomplete: For command-line completion'
-)
-# GitHub releases are not recommended by upstream (and fail to build anyway).
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/L/LinkChecker/LinkChecker-$pkgver.tar.gz")
-sha256sums=('ea9354665341c9f1650b6bb716a64d2022635e7fa38e5e05280ba79a57c237b2')
+depends=('python-beautifulsoup4' 'python-dnspython' 'python-requests')
+makedepends=('python-hatch-vcs' 'python-hatchling' 'python-installer' 'python-polib')
+optdepends=('python-argcomplete: For command-line completion')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('943a3f3f30279fbb85fc6f0569d808cf1ae4be0de4c2050c6f713429b8e58b59')
build() {
- cd "LinkChecker-$pkgver"
- python setup.py build
+ cd $pkgname-$pkgver
+ hatchling build
}
package() {
- cd "LinkChecker-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}